tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Diane Pitts <midpi...@gmail.com>
Subject Tomcat 6.0.35 NoClassDefFoundError on new .jsp
Date Thu, 01 Nov 2012 20:26:21 GMT
I have created a new .jsp.  It still says Hello World! I ran it to make
sure everything works okay before I make changes to it and incorporate it
into my project.  I am getting an error 500 when I run it.

More info:

HTTP Status 500 -
------------------------------

*type* Exception report

*message*

*description* *The server encountered an internal error () that prevented
it from fulfilling this request.*

*exception*

javax.servlet.ServletException: java.lang.NoClassDefFoundError:
javax/servlet/Servlet
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:268)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

*root cause*

java.lang.NoClassDefFoundError: javax/servlet/Servlet
	java.lang.ClassLoader.defineClass1(Native Method)
	java.lang.ClassLoader.defineClass(ClassLoader.java:791)
	java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
	java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
	java.net.URLClassLoader.access$100(URLClassLoader.java:71)
	java.net.URLClassLoader$1.run(URLClassLoader.java:361)
	java.net.URLClassLoader$1.run(URLClassLoader.java:355)
	java.security.AccessController.doPrivileged(Native Method)
	java.net.URLClassLoader.findClass(URLClassLoader.java:354)

Lots more to this message if you need it.

Steps I have taken:
  Googled and found that not having javaee.jar in tomcat lib could
cause this problem.  Putting it in didn't fix it.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message