tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: Mystery migrating from tomcat 6 to 7
Date Fri, 02 Nov 2012 20:33:13 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Fred,

On 11/2/12 4:25 PM, Fred Toth wrote:
> Well, let me post at least the last bit (the whole thing is noisy
> and long). See below for the indication of a normal startup. In
> particular, my app finishes startup with "initialized Struts-Spring
> integration successfully" and tomcat indicates it's done with
> "Server startup in 7487 ms".
> 
> Also, no amount of waiting changes behavior. Again, when I get my
> 404 errors, I get nothing in catalina.out, as if to say tomcat
> isn't even seeing the request as an error.
> 
> (Note also that I'm running on port 80 temporarily while
> debugging.)

Try enabling an AccessLogValve for both the <Host> and the <Context>.
If it shows up in the context's access log, then it's likely an
app-level configuration problem. Otherwise, Tomcat is not routing
properly for some reason.

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG/MacGPG2 v2.0.17 (Darwin)
Comment: GPGTools - http://gpgtools.org
Comment: Using GnuPG with Mozilla - http://www.enigmail.net/

iEYEARECAAYFAlCULgkACgkQ9CaO5/Lv0PDLNACdEDk7HEfGRXP9dea1Ptbsm70n
o9MAnio7qngpI2xZPZPT4R4Qn2BavpRy
=QNQZ
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message