tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: AW: AW: WebSockets and HTTPS problems
Date Thu, 11 Oct 2012 15:33:29 GMT
2012/10/11 Mark Thomas <markt@apache.org>:
> On 10/10/2012 19:57, Mark Thomas wrote:
>> On 10/10/2012 19:51, Steffen Heil (Mailinglisten) wrote:
>>> Hi
>>>
>>>> I just took a look at this. The examples work out of the box for HTTPS
>>> with
>>>> BIO but not with NIO. This looks like a Tomcat bug at this point.
>>>> I'll take a look.
>>>
>>> What would I need to do to switch to BIO for now?
>>
>> Change the protocol attribute for your connector. See the docs.
>>
>>> And does Comet work with BIO?
>>
>> No, but APR does. ( I haven't tested APR, HTTPS and WebSocket yet).
>>
>> If you can hang on for a few hours, I might have a fix for you.
>
> See if this fixes if for you:
> http://people.apache.org/~markt/dev/tomcat-7/v7.0.33-r1397089/apache-tomcat-7.0.33-r1397089.tar.gz
>
> This is not an official release. Use it at your own risk. I'll take it
> down again in a few days.
>

Mark, I see you committed the fix to trunk in
http://svn.apache.org/viewvc?view=revision&revision=1397086

but I do not see such commit for 7.0.x (only a changelog update in r1397089).
What am I missing?

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message