tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Sarazin <nicolas.sarazin....@gmail.com>
Subject mod_jk/1.2.32 - Error connecting to Tomcat only on one page
Date Thu, 20 Sep 2012 14:37:26 GMT
Hello all,

English is not my native language, please excuse typing errors.

I met a problem which I do not manage to explain...

My environement (one server) :

Server version : Apache Tomcat/5.5.26
Server built : Jan 28 2008 01:35:23
Server number : 5.5.26.0
OS Name : Linux (Red Hat Enterprise Linux Server release 5.2 (Tikanga))
OS Version : 2.6.18-92.el5
Architecture : i386
JVM Version : 1.6.0_06-b02
JVM Vendor : Sun Microsystems Inc.
Web server version : Apache/2.2.21 (Unix) mod_jk/1.2.32

Web server communicate with application server by AJP/13, module
mo_jk. My configuration :

Server.xml :

[...]
    <!-- Define an AJP 1.3 Connector on port 8011 -->
    <Connector port="8011"
               enableLookups="false" redirectPort="8443" debug="0"
               maxThreads="600" keepAlive="true" backlog="8192"
               minSpareThreads="25" maxSpareThreads="250"
               connectionTimeout="600000" protocol="AJP/1.3" />
[...]

worker.properties :

# define worker
worker.list=ajp13

# Set properties for ajp13 => tomcat
worker.ajp13.type=ajp13
worker.ajp13.host=localhost
worker.ajp13.port=8011
worker.ajp13.connection_pool_size=1200
worker.ajp13.connection_pool_timeout=600
worker.ajp13.socket_keepalive=true
worker.ajp13.socket_timeout=600

My VirtualHost :

[...]
  JkMount /* ajp13
[...]

Usually, it's work correctly, but sometime, only on certain pages,
woker can't connect to Tomcat. In my logs files, I have :

mod_jk.log :

[...]
[Wed Sep 19 19:23:05 2012][2923:47030846901328] [error]
ajp_service::jk_ajp_common.c (2626): (ajp13) connecting to tomcat
failed.
[Wed Sep 19 19:26:21 2012][2956:47030846901328] [error]
ajp_service::jk_ajp_common.c (2626): (ajp13) connecting to tomcat
failed.
[Wed Sep 19 19:26:27 2012][1941:47030846901328] [error]
ajp_service::jk_ajp_common.c (2626): (ajp13) connecting to tomcat
failed.
[Wed Sep 19 19:26:27 2012][2917:47030846901328] [error]
ajp_service::jk_ajp_common.c (2626): (ajp13) connecting to tomcat
failed.
[Wed Sep 19 19:26:28 2012][1821:47030846901328] [error]
ajp_service::jk_ajp_common.c (2626): (ajp13) connecting to tomcat
failed.
[Wed Sep 19 19:26:29 2012][2906:47030846901328] [error]
ajp_service::jk_ajp_common.c (2626): (ajp13) connecting to tomcat
failed.
[...]
[Wed Sep 19 19:27:11 2012][2926:47030846901328] [error]
ajp_service::jk_ajp_common.c (2626): (ajp13) connecting to tomcat
failed.
[...]

VirtualHost log file :

[...]
ipuser1 - - [19/Sep/2012:19:26:06 +0200] "GET /page1 HTTP/1.1" 200
49467 "-" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1;
Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR
3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)" 162574
ipuser1 - - [19/Sep/2012:19:26:21 +0200] "GET /page2 HTTP/1.1" 500 21
"http://servername/page1" "Mozilla/4.0 (compatible; MSIE 7.0; Windows
NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET
CLR 3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)" 104361
ipuser1 - - [19/Sep/2012:19:26:26 +0200] "GET /page2 HTTP/1.1" 500 21
"-" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0;
.NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648;
.NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)" 105824
ipuser1 - - [19/Sep/2012:19:26:27 +0200] "GET /page2 HTTP/1.1" 500 21
"-" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0;
.NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648;
.NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)" 105062
ipuser1 - - [19/Sep/2012:19:26:28 +0200] "GET /page2 HTTP/1.1" 500 21
"-" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0;
.NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648;
.NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)" 106297
ipuser1 - - [19/Sep/2012:19:26:29 +0200] "GET /page2 HTTP/1.1" 500 21
"-" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0;
.NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648;
.NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)" 105792
ipuser1 - - [19/Sep/2012:19:26:30 +0200] "GET /page2 HTTP/1.1" 500 21
"-" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0;
.NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648;
.NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)" 104940
[...]
ipuser1 - - [19/Sep/2012:19:27:08 +0200] "GET /page1 HTTP/1.1" 200
49095 "-" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1;
Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR
3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)" 352904
ipuser1 - - [19/Sep/2012:19:27:11 +0200] "GET /page2 HTTP/1.1" 500 21
"http://servername/page1" "Mozilla/4.0 (compatible; MSIE 7.0; Windows
NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET
CLR 3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)" 105703
ipuser1 - - [19/Sep/2012:19:27:17 +0200] "GET /page3 HTTP/1.1" 200
8882 "http://servername/page1" "Mozilla/4.0 (compatible; MSIE 7.0;
Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR
3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR
3.5.30729)" 411922
[...]

Take a look on requested pages :
- request on "/page1" return HTTP code 200
- request on "/page2" return HTTP code 500, and an error message is
logged in mod_jk.log
- request on "/page3" return HTTP code 200

I haven't error in application server logs.

At the beginning, I thought that the problem came from a bad
configuration here :
In server.xml file : maxThreads="600"
In worker.properties : worker.ajp13.connection_pool_size=1200

But at the present time, there was no overload on the servers.

How can we explain this behavior ?

Thank you in advance !

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message