tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From joel badia escolĂ  <basto...@gmail.com>
Subject Fwd: Problems loading external jar in my app !
Date Thu, 13 Sep 2012 05:42:30 GMT
Hello everyone, i have a problem with my jsp app for adding external
jars. First of all I have tried the same code and app directory
structure in netbeans ide "built-in" tomcat and works fine, but when i
try to serve my app in my tomcat installation (installed using
aptitude) it seems that it's impossible to locate the external jar.

Only with this code:

<%@page import="weka.classifiers.trees.RandomTree" %>

<%
RandomTree t = new RandomTree();
out.println();
out.println("It works");
%>

I get this error message:

org.apache.jasper.JasperException: Unable to compile class for JSP:

An error occurred at line: 6 in the generated java file
Only a type can be imported. weka.classifiers.trees.RandomTree
resolves to a package

An error occurred at line: 6 in the jsp file:
/DiseaseDiscover/make_diagnosis.jsp
RandomTree cannot be resolved to a type
3: <%@page import="weka.classifiers.trees.RandomTree" %>
4:
5: <%
6: RandomTree t = new RandomTree();
7: out.println();
8: out.println("It works");
9: %>

I tried to put weka.jar in all this directories my-app/WEB-INF/lib/ &
/var/lib/tomcat6/common/ & /var/lib/tomcat6/server/ &
/usr/share/tomcat6/lib/

In all directories I get the same error message.

Greetings,

Joel

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message