tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ferdie Romero <ferdierom...@gmail.com>
Subject Re: How to resolve:Recreate aclocal.m4 with macros from libtool during make of tomcat connector
Date Tue, 04 Sep 2012 03:37:41 GMT
On Sep 4, 2012 11:25 AM, "Ferdie Romero" <ferdieromero@gmail.com> wrote:
>
>
> On Sep 3, 2012 10:43 PM, "Ferdie Romero" <ferdieromero@gmail.com> wrote:
> >
> >
> >
> > On Mon, Sep 3, 2012 at 10:07 PM, Rainer Jung <rainer.jung@kippdata.de>
wrote:
> >>
> >> On 03.09.2012 15:46, Ferdie Romero wrote:
> >>>
> >>> The exact step is "make" and the error is
> >>
> >>
> >> I guess you are running configure first? yes, we use ./configure
--with-apache=prefix
> >>
> >> How does your configure command look like? Does it automatically find
your apxs or apxs2 or do you give the path to it as a configure flag?

--ยป we don't have apxs or apxs2, is this really required?

> >> What does "apxs -q LIBTOOL" (or "apxs2 -q LIBTOOL") return? Maybe you
need to add the path to apxs before calling it.
> >>
> >> -->we don't have apxs or apxs2, is this really required?
> >>
> >>
> >> When being inside the native directory of the mod_jk sources:
> >>
> >> What is the result of "grep -i libtool config.log" after running
configure?
> >> -->result is
connectors-1.2.37-src/native # grep -i libtool config.log
configure:9934: checking if libtool supports shared libraries
configure:10096: creating libtool configure:19290: result:
LIBTOOL="$(SHELL) $(top_builddir)/libtool" LIBTOOL='$(SHELL)
$(top_builddir)/libtool'

> >
> >>
> >> The same for "grep LIBTOOL Makefile"?
> >> -->we don't have Makefile in the src.directory of the connector
> >
> >
> >>
> >> The same for "grep macro_version= libtool"?
> >> -- >we don't have libtool in the src.directory of the connector
> >>
> >>
> >>> version mismatch error. This libtool 2.4.2 but the definition of this
> >>> LT_INIT comes from an older release. You should recreate aclocal.m4
with
> >>> macros from libtool 2.4.2 and run autoconf again.
> >>
> >>
> >> It seems it tries to use your own libtool instead of the one we
provide. We'll see after you respond to the above questions.
> >>
> >>
> >>> Based on the guide that we are using we need to perform ./configure,
make
> >>> and make install for the tomcat connector.
> >>
> >>
> >> If you have all the needed auto tools installed you could run
./buildconf.sh before running configure. This will recreate configure from
your own auto tools including libtool. But this is not recommended.
configure should work without running buildconf and no installed libtool
needed.
> >> --> we already tried using buildconf but we got the same error during
make.
> >
> >
> >
> > Thanks and really appreciate your assistance.
> >
> >
> >>
> >> Regards,
> >>
> >> Rainer
> >>
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> >> For additional commands, e-mail: users-help@tomcat.apache.org
> >>
> >

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message