tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralph Plawetzki <ra...@purejava.org>
Subject Re: Fwd: Problems loading external jar in my app !
Date Thu, 13 Sep 2012 18:03:16 GMT
Am 13.09.2012 07:42, schrieb joel badia escolĂ :
> Hello everyone, i have a problem with my jsp app for adding external
> jars. First of all I have tried the same code and app directory
> structure in netbeans ide "built-in" tomcat and works fine, but when i
> try to serve my app in my tomcat installation (installed using
> aptitude) it seems that it's impossible to locate the external jar.
> 
On which OS did you install tomcat6?

> I tried to put weka.jar in all this directories my-app/WEB-INF/lib/ &
> /var/lib/tomcat6/common/ & /var/lib/tomcat6/server/ &
> /usr/share/tomcat6/lib/
> 
If your OS would be Debian or Ubuntu, /usr/share/tomcat6/lib/ is the
place to make weka.jar available for all webapps on tomcat. After
dropping it in there, did you restart tomcat?

Have you checked the file permissions of weka.jar? It has to be readable
for the user tomcat6 is running with.

Regards,
Ralph

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message