tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: How to resolve:Recreate aclocal.m4 with macros from libtool during make of tomcat connector
Date Mon, 03 Sep 2012 14:07:50 GMT
On 03.09.2012 15:46, Ferdie Romero wrote:
> The exact step is "make" and the error is

I guess you are running configure first?

How does your configure command look like? Does it automatically find 
your apxs or apxs2 or do you give the path to it as a configure flag?

What does "apxs -q LIBTOOL" (or "apxs2 -q LIBTOOL") return? Maybe you 
need to add the path to apxs before calling it.

When being inside the native directory of the mod_jk sources:

What is the result of "grep -i libtool config.log" after running configure?

The same for "grep LIBTOOL Makefile"?

The same for "grep macro_version= libtool"?

> version mismatch error. This libtool 2.4.2 but the definition of this
> LT_INIT comes from an older release. You should recreate aclocal.m4 with
> macros from libtool 2.4.2 and run autoconf again.

It seems it tries to use your own libtool instead of the one we provide. 
We'll see after you respond to the above questions.

> Based on the guide that we are using we need to perform ./configure, make
> and make install for the tomcat connector.

If you have all the needed auto tools installed you could run 
./buildconf.sh before running configure. This will recreate configure 
from your own auto tools including libtool. But this is not recommended. 
configure should work without running buildconf and no installed libtool 
needed.

Regards,

Rainer


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message