tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Massimo Chirivì - Ict Consultant <i...@massimochirivi.net>
Subject Re: TOMCAT with multiple sites (one on https, others on http)
Date Tue, 07 Aug 2012 13:03:45 GMT
I have configured the server.xml to run a few sites with HTTP and HTTPS,
HTTP sites work correctly, that HTTPS is not responding, can not display
the page

Massimo Chirivì


--------------------------------------------------------------------------------------------------------



2012/8/7 Pid <pid@pidster.com>

> On 03/08/2012 17:35, Massimo Chirivì - Ict Consultant wrote:
> > *this is my server.xml, *
> > *the sites on the http is ok, but the site on the https is not ok?*
> > *thank you for help*
>
> Are you just repeating the same question over & over?
>
> Have you read the documents provided previously?
>
> What version of Tomcat are you using?
>
> What *exactly* does 'not ok' mean?
>
> Are there any errors in the log files?
>
> Can you describe the symptoms of the error?
>
> Have you ever read & comprehended:
>
>  http://www.catb.org/esr/faqs/smart-questions.html
>
>
> p
>
>
> > <?xml version='1.0' encoding='utf-8'?>
> >
> > <Server port="8005" shutdown="SHUTDOWN">
> >
> >   <Listener className="org.apache.catalina.core.AprLifecycleListener"
> > SSLEngine="on" />
> >   <Listener className="org.apache.catalina.core.JasperListener" />
> >   <Listener
> className="org.apache.catalina.mbeans.ServerLifecycleListener"
> > />
> >   <Listener
> > className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener"
> />
> >
> >   <GlobalNamingResources>
> >     <Resource name="UserDatabase" auth="Container"
> >               type="org.apache.catalina.UserDatabase"
> >               description="User database that can be updated and saved"
> >
> factory="org.apache.catalina.users.MemoryUserDatabaseFactory"
> >               pathname="conf/tomcat-users.xml" />
> >   </GlobalNamingResources>
> >
> >   <Service name="Catalina">
> >
> >
> >     <Connector port="80" protocol="HTTP/1.1"
> >                connectionTimeout="20000"
> >                redirectPort="443" />
> >
> >     <Connector port="8009" protocol="AJP/1.3" redirectPort="443" />
> >
> >
> >     <Engine name="Catalina" defaultHost="localhost">
> >
> >       <Realm className="org.apache.catalina.realm.UserDatabaseRealm"
> >              resourceName="UserDatabase"/>
> >
> >       <Host name="localhost"  appBase="webapps"
> >             unpackWARs="true" autoDeploy="true"
> >             xmlValidation="false" xmlNamespaceAware="false">
> >       </Host>
> >
> >       <Host name="www.site1.it" debug="0" unpackWARs="true">
> >         <Logger className="org.apache.catalina.logger.FileLogger"
> >                  directory="logs"  prefix="virtual_log1." suffix=".txt"
> > timestamp="true"/>
> >         <Context path="" docBase="/webapps/site1" debug="0"
> > reloadable="true"/>
>
> Context definitions in server.xml is very strongly discouraged and
> considered poor practice.
>
>
> >         <Valve className="org.apache.catalina.valves.AccessLogValve"
> >                  directory="logs"  prefix="virtual_log." suffix=".txt"
> >                  pattern="common"/>
> >       </Host>
> >
> >
> > <Host name="www.site2.net" debug="0" unpackWARs="true" >
> > <Logger className="org.apache.catalina.logger.FileLogger"
> >                  directory="logs"  prefix="virtual_log29." suffix=".txt"
> > timestamp="true"/>
>
> There is no logger in Tomcat 7.0.
>
>
> >         <Context path="" docBase="/webapps/site2" debug="0"
> > reloadable="true"/>
> >         <Valve className="org.apache.catalina.valves.AccessLogValve"
> >                  directory="logs"  prefix="virtual_log." suffix=".txt"
> >                  pattern="common"/>
> > </Host>
> >
> >     </Engine>
> >   </Service>
> >
> >
> >   <Service name="Catalinassl">
> >
> >     <Engine name="Catalinassl" defaultHost="localhost">
> > <Connector port="443" maxHttpHeaderSize="8192" maxThreads="150"
> > minSpareThreads="25" maxSpareThreads="75" enableLookups="false"
> > disableUploadTimeout="true" acceptCount="100" scheme="https"
> secure="true"
> > SSLEnabled="true" clientAuth="false" sslProtocol="TLS"
> keyAlias="bancomed"
> > keystoreFile="C:\Program Files\Java\jre1.5.0_15\bin\site3.jks"
> > keypass="xxxx" />
> >
> >   <Host name="www.site3.net" debug="0" unpackWARs="true">
> > <Logger className="org.apache.catalina.logger.FileLogger"
> >                  directory="logs"  prefix="virtual_log29." suffix=".txt"
> > timestamp="true"/>
>
> There is no logger in Tomcat 7.0.
>
> >         <Context path="" docBase="/webapps/site3" debug="0"
> > reloadable="true"/>
>
> Context definitions in server.xml is very strongly discouraged and
> considered poor practice.
>
>
> >         <Valve className="org.apache.catalina.valves.AccessLogValve"
> >                  directory="logs"  prefix="virtual_log." suffix=".txt"
> >                  pattern="common"/>
> > </Host>
> >   </Engine>
> >
> >   </Service>
> >
> >
> >
> > </Server>
> >
> > Massimo Chirivì
> >
> >
> >
> >
> >
> > 2012/2/12 Caldarale, Charles R <Chuck.Caldarale@unisys.com>
> >
> >> From: mchirivi.ict@gmail.com [mailto:mchirivi.ict@gmail.com] On Behalf
> Of
> >> Massimo Chirivì - Ict Consultant
> >> Subject: Re: TOMCAT with multiple sites (one on https, others on http)
> >>
> >> i have a server with TOMCAT and i want to configure multiple sites,
> >> i can configure one site on https and others sites on http?
> >>
> >> 1) Read the servlet spec, especially section 13, security.
> >>
> >> 2) Read the Tomcat doc for SSL and <Connector>:
> >> http://tomcat.apache.org/tomcat-7.0-doc/ssl-howto.html
> >> http://tomcat.apache.org/tomcat-7.0-doc/config/http.html
> >>
> >> 3) Read the Wiki for virtual hosts:
> >>
> >>
> http://wiki.apache.org/tomcat/HowTo#How_do_I_set_up_Tomcat_virtual_hosts_in_a_development_environment.3F
> >>
> >>  - Chuck
> >>
> >>
> >> THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY
> >> MATERIAL and is thus for use only by the intended recipient. If you
> >> received this in error, please contact the sender and delete the e-mail
> and
> >> its attachments from all computers.
> >>
> >>
> >
>
>
> --
>
> [key:62590808]
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message