tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ijlal EL HAZITI <ijlal....@gmail.com>
Subject error while shutting down tomcat
Date Tue, 14 Aug 2012 22:32:15 GMT
Good evening


I installed a wab application (sakai precisely) on a distant server
remotely, but it doesn't start, and when I shutdown tomcat, I get that
error:

Using CATALINA_BASE:   /opt/tomcat
Using CATALINA_HOME:   /opt/tomcat
Using CATALINA_TMPDIR: /opt/tomcat/temp
Using JRE_HOME:        /opt/java
Using CLASSPATH:
/opt/tomcat/bin/bootstrap.jar:/opt/tomcat/bin/tomcat-juli.jar
14 août 2012 13:55:44 org.apache.catalina.startup.Catalina stopServer
*GRAVE: Catalina.stop:
java.net.ConnectException: Connection refused*
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:351)
    at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:213)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:200)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
    at java.net.Socket.connect(Socket.java:529)
    at java.net.Socket.connect(Socket.java:478)
    at java.net.Socket.<init>(Socket.java:375)
    at java.net.Socket.<init>(Socket.java:189)
    at org.apache.catalina.startup.Catalina.stopServer(Catalina.java:490)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.catalina.startup.Bootstrap.stopServer(Bootstrap.java:371)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:453)

tomcat instance starts fine.

before deploying sakai, there were no errors while starting or shutting
down tomcat.

>From a search on google, I understood that it could be a firewall or port
problem, so, I disabled the firewall, and all the ports that are mentionned
in the conf/server.xml aren't used by other processes.

I appreciate your help.

Regrards

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message