tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeffrey Janner <Jeffrey.Jan...@PolyDyne.com>
Subject RE: tomcat and DB oracle problem - only in higher versions
Date Fri, 17 Aug 2012 22:07:44 GMT
Yes, you really want ot match the OJDBC version to the Java version.  The trailing number tells
you what Java version the library was compiled under.
From experience, ojdbc14 works just fine with Java5, but not Java6.  Java6 really wants the
ojdbc6 library, but you need to be careful about the version of the ojdbc library you use.
 The 11.2.x version has some changes to mapped types that could give you fits if you aren't
prepared for it.
In other words, before randomly upgrading to a new version of any library, be sure you've
read through the CHANGES documents and make sure nothing was changed that will affect you
-- and then test the hell out of it!

> -----Original Message-----
> From: Propes, Barry L [mailto:barry.l.propes@citi.com]
> Sent: Friday, August 17, 2012 9:13 AM
> To: 'Tomcat Users List'
> Subject: RE: tomcat and DB oracle problem - only in higher versions
> 
>  Yes, I believe you do. I had to change to that -- odbc6 -- upon moving
> to JDK 1.6.
> 
> Which I swore I had or needed to do when moving from Tomcat 4.1.3, but
> maybe I don't recall that part correctly.
> 
> -----Original Message-----
> From: Busfy,Peter [mailto:Peter.Busfy@drei.com]
> Sent: Friday, August 17, 2012 2:11 AM
> To: Tomcat Users List
> Subject: RE: tomcat and DB oracle problem - only in higher versions
> 
> Hi Jeffrey,
> 
> actually we use ojdbc14.jar.  And it is version 10.2.0.2.0.
> Maybe I should really try ojdbc6.jar because ojdbc4.jar is for jdk4.
> I will try it and let you know.
> 
> Peter Busfy
> 3 Portal
> 
> Hutchison 3G Austria GmbH
> Gasometer C
> Guglgasse 12/10/3
> 1110 Vienna
> Mobil: +43-660-7313346
> mailto:peter.busfy@drei.com
> http://www.drei.at
> 
> 
> -----Original Message-----
> From: Jeffrey Janner [mailto:Jeffrey.Janner@PolyDyne.com]
> Sent: Thursday, August 16, 2012 4:33 PM
> To: 'Tomcat Users List'
> Subject: RE: tomcat and DB oracle problem - only in higher versions
> 
> Peter -
> I'm not a complete expert, but it appears to me that the error is
> saying it needs the Oracle JDBC drivers to do LOB work.
> What is the version of ojdbc6.jar do you have in your classpath?
> You really want the 11.2.0.3 version, particularly with that version of
> Java.
> Jeff
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 

__________________________________________________________________________

Confidentiality Notice:  This Transmission (including any attachments) may contain information
that is privileged, confidential, and exempt from disclosure under applicable law.  If the
reader of this message is not the intended recipient you are hereby notified that any dissemination,
distribution, or copying of this communication is strictly prohibited.  

If you have received this transmission in error, please immediately reply to the sender or
telephone (512) 343-9100 and delete this transmission from your system.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message