tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Miguel González Castaños <miguel_3_gonza...@yahoo.es>
Subject Re: Tomcat 7.x and Internet Explorer Adobe Reader plugin
Date Wed, 22 Aug 2012 20:31:42 GMT
> We are having what sounds like a similar problem (although 7.0.26 works for us) and can
provide our details.
>
> We are using Solaris 10, Tomcat 7.0.26, Apache/2.2.16, mod_jk/1.2.35 and Java(TM) SE
Runtime Environment (build 1.6.0_30-b12) in our production environment. We are using the same
except for the latest Tomcat 7.0.29 in our test environment.
>
> Recently one of our testers found that when using IE8 against our test environment she
could not download PDFs (available as links on web pages) and would instead see the error
"A network error occurred while accessing this document on the Internet" but it worked fine
on the older Tomcat in production.  Indeed if I roll our testing environment back to Tomcat
7.0.26, this problem does not occur.  It also doesn't occur in any other browser we tried
(IE9, FireFox 14.0.1 and Safari 5.1.7).
>
> I had remembered that something similar had been discussed on this list, but the archived
thread looks like it went stale when it couldn't be reproduced:
> PDF Download problem tomcat >= 7.0.27 (http://mail-archives.apache.org/mod_mbox/tomcat-users/201207.mbox/%3CCAC=HunuF5zqKf5s_D9syTZ1J2nFXdCjEWKj=zQ+Hc8BgnN1hzA@mail.gmail.com%3E)
>
> A good portion of our visitors use IE8 with the 9.5.1 Adobe Reader and we have a number
of PDF documents available for download so I'm hoping perhaps our different configuration
to the ones previously reported might eventually lead to a fix.

As I have answered to Chris, it came down that the downgrade to 7.0.26 
fixed it. Only a person reports problems that with a particular PDF file 
so we have assumed it's an issue with his setup. I couldn't reproduce 
the issue as I did with 7.0.29, so it seems there is something wrong 
with that version.

Thanks!

Miguel

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message