tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Byrne <john_by...@apple.com>
Subject Re: %{xxx}t not working
Date Tue, 21 Aug 2012 17:05:35 GMT
Thank you Rainer,

It turns out I was still using 7.0.8 even though I switched the soft link to the new version.
 Now I just need to find out how the switch mechanism works.

John


John Byrne
System Administrator, IS&T
john_byrne@apple.com




On Aug 21, 2012, at 1:10 AM, Konstantin Kolinko wrote:

> 7.0.8 is out of question.
> 
> In 7.0.29 the pattern works.
> server.xml:
> [[[
>        <Valve className="org.apache.catalina.valves.AccessLogValve"
> directory="logs"
>               prefix="localhost_access_log." suffix=".txt"
>               pattern="%h %l %u %t &quot;%r&quot; %s %b
> %{yyyy-MM-dd'T'HH:mm:ss,SSSZ}t" />
> ]]]
> 
> localhost_access_log.2012-08-21.txt:
> [[[
> 127.0.0.1 - - [21/Aug/2012:12:08:35 +0400] "GET / HTTP/1.1" 200 11444
> 2012-08-21T12:08:35,375+0400
> 127.0.0.1 - - [21/Aug/2012:12:08:36 +0400] "GET /tomcat.css HTTP/1.1"
> 200 5926 2012-08-21T12:08:36,187+0400
> 127.0.0.1 - - [21/Aug/2012:12:08:36 +0400] "GET /tomcat.png HTTP/1.1"
> 200 5103 2012-08-21T12:08:36,218+0400
> ]]]
> 
> 2012/8/20 John Byrne <john_byrne@apple.com>:
>> I've tried both 7.0.29 and 7.0.8.
>> 
>> Thank you for the help.
>> 
>> John Byrne
>> 
>> 
>> John Byrne
>> System Administrator, IS&T
>> john_byrne@apple.com
>> 
>> 
>> 
>> 
>> On Aug 20, 2012, at 12:43 PM, Konstantin Kolinko wrote:
>> 
>>> 2012/8/20 John Byrne <john_byrne@apple.com>:
>>>> 
>>>> 
>>>>> I was wondering if you could help me with a server.xml log question.
 I'm trying to format the times that go into the logs but not having any success.  The output
always ends up as : ???.  I've read that any time format accepted by Java's SimpleDateFormat
will work but this one doesn't seem to be working.
>>>>> 
>>>>> The time/date format is: %{yyyy-MM-dd'T'HH:mm:ss,SSSZ}t
>>>>> 
>>>>> The whole log format line is:
>>>>> <Valve className="org.apache.catalina.valves.AccessLogValve" directory="${splunk.accesslogs}"
prefix="${serviceName}_${port.http.nonssl}_access_" suffix=".log" pattern="%{yyyy-MM-dd'T'HH:mm:ss,SSSZ}t
thread=%I client=%a url=&quot;%r&quot; query=%q status=%s time=%D size=%B agent=&quot;%{User-Agent}i&quot;"
resolveHosts="false" />
>>>>> 
>>>>> Everything works except the %{xxx}t "variable".
>>>>> i.e. the output log line is:
>>>>> ??? thread="http-bio-26258"-exec-10 client=17.169.48.254 url="GET /iTranslate/index
HTTP/1.1" query= status=200 time=449 size=8205 agent="Mozilla/5.0 (Macintosh; Intel Mac OS
X 10_7_4) AppleWebKit/536.25 (KHTML, like Gecko) Version/6.0 Safari/536.25"
>>>>> 
>>>>> (notice the ??? -- that's where the time/date formatted output should
go.
>>>>> 
>>>>> 
>>>>> Can any one help me with this?
>>> 
>>> Your Tomcat version = ?
>>> 
>>> IIRC, support for %{xxx}t was added less than a year ago.
>>> 
>> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message