tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "浪迹寰尘" <laogong_4...@qq.com>
Subject Apache-tomcat-7.0.29 can't startup in my computer.
Date Wed, 11 Jul 2012 15:15:55 GMT
hi,
I use windows xp OS.
The tomcat(apache-tomcat-7.0.29) had works very well until last week.
But now it can't startup .
The informations in the log file are as bellow:
"
Exception in thread "main" 
2012-07-11 21:54:22 Commons Daemon procrun stderr initialized
java.lang.NoClassDefFoundError: org/apache/juli/logging/LogFactory
 at org.apache.catalina.startup.Bootstrap.<clinit>(Bootstrap.java:60)
Caused by: java.lang.ClassNotFoundException: org.apache.juli.logging.LogFactory
 at java.net.URLClassLoader$1.run(Unknown Source)
 at java.net.URLClassLoader$1.run(Unknown Source)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.net.URLClassLoader.findClass(Unknown Source)
 at java.lang.ClassLoader.loadClass(Unknown Source)
 at java.lang.ClassLoader.loadClass(Unknown Source)
 ... 1 more
Exception in thread "main" 
 
"
It seems that I don't add the "tomcat-juli.jar" in the "classpath" system parameters, but
I has did that.
I even edit a helloworld.java as bellow:
"
import org.apache.juli.logging.LogFactory;
public class hello_world{
   public static void main( String[] args ){
      System.out.println( "Hello world!" );
   }
 }  
"
I compile helloworld.java and it is accepted by the compile which is means that I do add "tomcat-juli.jar"
in the "classpath" system parameters.
 
 
Looking forword to your answer!
 
Great thx!
                                                jack
Mime
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message