tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Pizey <tim.pi...@gmail.com>
Subject Re: Tomcat7 deployment url change - please maintain backwards compatibility
Date Fri, 13 Jul 2012 14:10:27 GMT
On 13 July 2012 14:05, Christopher Schultz wrote:
> Tim,
>
> On 7/13/12 8:11 AM, Tim Pizey wrote:
>> In the hope of helping future users: the migration guide is here:
>> http://tomcat.apache.org/migration-7.html
>
> Hopefully, users will find that guide more easily from the Tomcat home
> page (cleverly hidden behind the text "Migration Guide"), and not
> waste their time searching the archives for it.
>
> - -chris

Thanks for your input.

I only joined this list this morning, and am appalled by the lack of
constructive responses.

I have just upgraded to tomcat7, it works, great, and has solved a
problem I had, great.

However I thought that my problems with redeployment were worth feeding back:

The new deployment url granularity seems like an improvement, however
I am finding that the
rationale for not providing a default for backwards compatibility is
not explained,
and of the three maven plugins only the old one works:
Given properties:
<properties>
    <tomcat.username>admin</tomcat.username>
    <tomcat.password></tomcat.password>
    <tomcat.username>admin</tomcat.username>
    <tomcat.password></tomcat.password>
    <!-- tomcat7 needs /text appended -->
    <tomcat.url>http://localhost:8080/manager</tomcat.url>
</properties>

and plugins

      <plugin>
        <groupId>org.apache.tomcat.maven</groupId>
        <artifactId>tomcat6-maven-plugin</artifactId>
        <version>2.0-beta-1</version>
        <configuration>
          <path>/${project.artifactId}</path>
          <url>${tomcat.url}</url>
          <username>${tomcat.username}</username>
          <password>${tomcat.password}</password>
        </configuration>
      </plugin>
      <plugin>
        <groupId>org.apache.tomcat.maven</groupId>
        <artifactId>tomcat7-maven-plugin</artifactId>
        <version>2.0-beta-1</version>
        <configuration>
          <path>/${project.artifactId}</path>
          <url>${tomcat.url}</url>
          <username>${tomcat.username}</username>
          <password>${tomcat.password}</password>
        </configuration>
      </plugin>
      <plugin>
        <groupId>org.codehaus.mojo</groupId>
        <artifactId>tomcat-maven-plugin</artifactId>
        <version>1.1</version>
        <configuration>
          <path>/${project.artifactId}</path>
          <url>${tomcat.url}</url>
          <username>${tomcat.username}</username>
          <password>${tomcat.password}</password>
        </configuration>
      </plugin>

the only command which works for me (Maven 3.0.4) is :
mvn  install tomcat:redeploy  -Dtomcat.url=http://localhost:8080/manager/html
Failures:
mvn  install tomcat:redeploy  -Dtomcat.url=http://localhost:8080/manager/text
mvn  install tomcat6:redeploy  -Dtomcat.url=http://localhost:8080/manager/text
mvn  install tomcat7:redeploy  -Dtomcat.url=http://localhost:8080/manager/text
mvn  install tomcat6:undeploy tomcat6:deploy
-Dtomcat.url=http://localhost:8080/manager/text
mvn  install tomcat7:undeploy tomcat7:deploy
-Dtomcat.url=http://localhost:8080/manager/text

I am not asking for help and would be very happy not to have any RTFM replies.

yours
Tim


-- 
Tim Pizey - http://pizey.net/~timp

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message