tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wei, Mingzhen" <w...@mst.edu>
Subject RE: Tomcat building problems: Apache Tomcat 5.5 Servelet/JSP container
Date Tue, 10 Jul 2012 15:43:34 GMT
Konstantin Kolinko,

Could you tell me the point in more detail? I am new with Tomcat and need it badly to be able
to run another application. 

Do you mean I need to try the combination of ant5.5 download + Ant 1.8.4 and JDK 1.4.2_19?

Thanks. 

-----------------------------------------------------------------------------------------------
Mingzhen Wei, PhD
Assistant Research Professor
Petroleum Engineering Program
Department of Geological Sciences and Engineering
330 McNutt Hall, 1400 N. Bishop Ave.
Missouri University of Science and Technology
Rolla, Missouri   65409-0410

Email:  weim@mst.edu 

Office phone:  (573) 341-4657      
Cell phone:  (573) 201-3924
Fax: (573)-341-6935
-----------------------------------------------------------------------------------------------

-----Original Message-----
From: Konstantin Kolinko [mailto:knst.kolinko@gmail.com] 
Sent: Friday, July 06, 2012 2:56 PM
To: Tomcat Users List
Subject: Re: Tomcat building problems: Apache Tomcat 5.5 Servelet/JSP container

2012/7/6 Christopher Schultz <chris@christopherschultz.net>:
>
> On 7/6/12 12:54 PM, Konstantin Kolinko wrote:
>> 2012/7/6 Wei, Mingzhen <weim@mst.edu>:
>>> I was trying to build Apache Tomcat 5.5 Servelet for another 
>>> application. I followed the steps from the link:
>>> http://tomcat.apache.org/tomcat-5.5-doc/building.html. I have done 
>>> the following:
>>>
>>> 1.       Installed JDK1.6
>>>
>>> 2.       Download and installed Apache Ant 1.8.4
>>>
>>> 3.       Download Tomcat 5.5 source package in zip file
>>>
>>> 4.       Set and updated the environment parameters for
>>> JAVA_HOME, PATH, ANT_HOME
>>>
>>> I cannot run the following step "ant download" correctly. It 
>>> complains the "includeantruntime" setup, and alerting me with errors 
>>> for classes as BasicDataSource, DelegatingStatement, 
>>> DelegatingPreparedStatement, and many more. The errors say that 
>>> those classes as not abstract and do not override the abstract 
>>> methods in other sources.
>>
>> 1. You need JDK 1.4 to build Tomcat 5.5. 2. The version of Ant 
>> targeted by the build script is 1.6.2.
>
> With only a little bit of digging, I couldn't find an earliest-version 
> of Ant that supports the "includeAntRuntime" attribute for <javac>.
> But, I suspect that 1.6.2 *does* support it, so there doesn't seem to 
> be a reason not to specify a value for it in the build file. That will 
> allow Tomcat 5.5 to be built with later ant versions (but, of course, 
> using the proper JDK version).

It is an interesting note. Anyway,
1. "ant download deploy" in 5.5 builds correctly with Ant 1.8.4 and JDK 1.4.2_19.  So I do
not see what the fix will bring besides a silenced warning.

2. Anyone may propose a patch for 5.5 (either in STATUS or in bugzilla).

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message