tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ermal Aliraj <ermal.ali...@gmail.com>
Subject Re: WebApp on Tomcat recognize automaticely uploaded file
Date Fri, 01 Jun 2012 15:14:13 GMT
I know is strange but webAppA, started to work suddenly.
The only thing I have done this days is a lot of restarts when deploying
stuff for webAppB. Now seems that each image uploaded through webAppB,
inside c:/pathtoDocbase/webAppA/uploads/ (or pasted directly in file
system) is been replied(showed in the browser) correctly when doing a http
request like http://servername/webAppA/uploads/1.jpg

Maybe is a configuration parameter that I have changed without noticing it,
but I am not sure.

Thank you for your reply.



2012/5/19 André Warnier <aw@ice-sa.com>

> Ermal Aliraj wrote:
>
>> Yes, I say webAppA do not recognize the images because do not serve them
>> through the browser via URL
>
>
>> I did the following scneario and writing down in case can make the
>> situation more clear
>> uploaded manualy the following files on:
>>
>> webAppA/uploads/1.jpg
>> webAppB/uploads/1.jpg
>>
>> requesting the files through URL i have the following:
>>
>> www.localhost/webAppA/uploads/**1.jpg     --- no reply
>>
>
> "no reply" cannot be.  What /exactly/ happens when you enter that URL ?
>
> Have you verified that the user under which tomcat runs has permissions to
> read what is in "webAppA" ?
>
>
>  www.localhost/webAppB/uploads/**1.jpg     -- photo visualized
>>
>>
>
> ------------------------------**------------------------------**---------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.**apache.org<users-unsubscribe@tomcat.apache.org>
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message