tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Tomcat uses 99% of CPU - Something to do with AJP connector
Date Mon, 11 Jun 2012 16:39:16 GMT
2012/6/11 Dharamshila Khandelwal <dharmshila.k@gmail.com>:
> Hi,
>
> I use a combination of tomcat (version 6.0.32) and apache (version 2.2.17)
> connected by mod_proxy_ajp connector.
> The website starts responding slow all of a sudden and I see that tomcat
> process uses 99% of the CPU.
> At the same time I see the following in apache error_log:
>
> [Sun Jun 10 00:20:36 2012] [error] (70007)The timeout specified has
> expired: ajp_ilink_receive() can't receive header
> [Sun Jun 10 00:20:36 2012] [error] ajp_read_header: ajp_ilink_receive failed
> [Sun Jun 10 00:20:36 2012] [error] (120006)APR does not understand this
> error code: proxy: read response failed from 10.128.18.60:9393 (
> roplws01.hsn.net)
>

It might be anything.  You have to take a thread dump,  or better
several (3) dumps with small intervals between them to see what is
actually going on.

How to take the thread dumps is mentioned in the FAQ.

Any chance for upgrade to 6.0.35 or to Tomcat 7?

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message