tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: isHexDigit error problems and upgrading Tomcat and jdk
Date Wed, 06 Jun 2012 22:54:09 GMT
2012/6/7 Miguel González Castaños <miguel_3_gonzalez@yahoo.es>:
> Hi,
>
>  We are getting isHexDigit errors again, although there is no malformed URL
> requests

It is parameter parsing code. It cannot claim the request as malformed
(API does not allow it). It can only skip malformed parameters.

It sets some error flag that can be examined. FailedRequestFilter is
example of a filter that checks that flag.

>  We are using Tomcat 5.5 and jdk 1.5 (from Sun). As some of you have
> suggested me in the past, I'm considering to upgrade to a more up-to-date
> Tomcat and/or jdk so I can get more support and help from the community
> since probably the stability issues are solved in newer versions. I have set
> up a test environment and Tomcat 7.0.27 and jdk 1.7 seems to work fine.
>
>  Do you suggest me to upgrade to Tomcat 6 or 7? What about jdk? 1.6 or 1.7?

1.6 is more widely tested (many years), but for a new system I would
go with 1.7.

I heard that Oracle plans to stop provide free updates for 1.6 this
summer. So they will be available only as "Java for Business".

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message