tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: Adding the manager app to a Standalone tomcat install
Date Thu, 03 May 2012 16:28:12 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Todd,

On 5/3/12 12:13 PM, Todd Seidenberg wrote:
> However, when I click on the tomcat manager link, I get: HTTP
> Status 404 - /manager/html

:(

> Here's what I've done.
> 
> - I've determined the version of Tomcat that my standalone install
> is using (6.0.32.)
> 
> - I've grabbed a tar.gz of the 6.0.32 standard tomcat and untarred
> it.
> 
> - I've rsync'd the  apache-tomcat-6.0.32/webapps/manager directory
> to my standalone installation's webapp directory.
> 
> - I noted that I had NOTHING in my server.xml for the manager app.
> (I do have context clauses in the server.xml for the main app that
> the standalone tomcat was bundled with.)
> 
> - I made sure that tomcat was killed.
> 
> - I then started it up and tailed the log file (Note that the app
> I'm running is called 'confluence.' It is running as expected.

Thanks for giving us that. Most people don't.

> SEVERE: The web application [/confluence] created a ThreadLocal
> with key of type
> [com.opensymphony.xwork.ActionContext.ActionContextThreadLocal]
> (value 
> [com.opensymphony.xwork.ActionContext$ActionContextThreadLocal@132ba74])
>
> 
and a value of type [com.opensymphony.xwork.ActionContext] (value
> [com.opensymphony.xwork.ActionContext@16f488d]) but failed to
> remove it when the web application was stopped. This is very likely
> to create a memory leak.

You might want to tell Confluence about these: they can really kill
your serer if you do a lot of hot-redeployments.

> WARNING: [SetPropertiesRule]{Server} Setting property 'debug' to
> '0' did not find a matching property. WARNING:
> [SetPropertiesRule]{Server/Service/Engine} Setting property 'debug'
> to '0' did not find a matching property. WARNING:
> [SetPropertiesRule]{Server/Service/Engine/Host} Setting property 
> 'debug' to '0' did not find a matching property. WARNING:
> [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting 
> property 'debug' to '0' did not find a matching property.

I'm seeing a pattern, here. You should remove the "debug" attributes
from those elements as they have not been a part of Tomcat since .. I
dunno 4.x?

> INFO: Deploying configuration descriptor manager.xml

Good.

> As you can see, the manager descriptor is deployed - and sure
> enough the standard manager.xml file is created in 
> /usr/local/confluence-4/conf/Standalone/localhost.

Good.

> However, I still don't get the manager app.

Bad. You mean you get a 404 Not Found?

It doesn't look like you are using anything in front of Tomcat like
httpd, are you? Do you have more than one <Host> in your server.xml?

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG/MacGPG2 v2.0.17 (Darwin)
Comment: GPGTools - http://gpgtools.org
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk+ishwACgkQ9CaO5/Lv0PAfDwCeNxhvYfRaa/INxLjxSnwrPd7v
PsIAn00I3c3k2At9KdebWMWQAWnhJnsM
=PFCq
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message