tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Eggers <its_toas...@yahoo.com>
Subject Re: tomcat deps on ant which deps on junit ... BUILD FAILED
Date Tue, 01 May 2012 02:00:49 GMT
----- Original Message -----

> From: Albretch Mueller <lbrtchx@gmail.com>
> To: Tomcat Users List <users@tomcat.apache.org>
> Cc: 
> Sent: Monday, April 30, 2012 4:07 PM
> Subject: Re: tomcat deps on ant which deps on junit ... BUILD FAILED
> 
>>  Exactly what Tomcat distribution (and from where) are you trying to 
> install?
> ~
> Well, I got the source code from:
> ~
> http://apache.claz.org/tomcat/tomcat-7/v7.0.27/src/apache-tomcat-7.0.27-src.tar.gz
> ~
> and followed the build instructions
> ~
> lbrtchx


Well, that was fun . . . I've never built this on a Windows platform before.

1. Downloaded a copy of the source in zip format
2. Unpacked it
3. Copied build.properties.default to build.properties
4. Edited build.properties
   a. aimed the download repo area to something sensible
      C:\Users\mdeggers\src\tc7-repo
   b. Added the following lines so I wouldn't build the Windows installer
      # right after base.path
      # skipping windows installer
        skip.installer=true
5. Opened up a command window and changed to the proper directory
6. ant release

This took a little over 4 minutes running on a 3.2 GHz core duo with 6 GB memory and Windows
7 Home Premium. I'm using JDK 1.6.0_32 and Ant 1.8.3. I've not customized my Ant yet (with
JUnit and XMLTask).

Worked fine for me.

. . . . just my two cents.
/mde/

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message