tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ashima Sharma <ashpr...@gmail.com>
Subject Intermittent "ServletException - Unable to compile class for JSP" for a struts-1.3.10 web-app with Tomcat 7.0.26/7.0.27
Date Wed, 11 Apr 2012 15:05:43 GMT
We just did a tomcat upgrade (from 6.0.36 to 7.0.26) for a legacy
struts-1.3.10 app on Windows 2008 R2 (64-bit).
Ever since, there's been an intermittent occurence of the following 2
exceptions (for random jsps) -

*2012-04-10 18:27:45,751 ERROR [org.apache.struts.tiles.taglib.InsertTag] -
ServletException in '/WEB-INF/pages/registration/registration.jsp': Unable
to compile class for JSP: *
*An error occurred at line: 49 in the generated java file*
*This method must return a result of type Map<String,Long>*
*
*
*AND*
*
*
*
2012-04-10 18:36:58,501 ERROR [org.apache.struts.tiles.taglib.InsertTag] -
ServletException in '/WEB-INF/pages/registration/registration.jsp':
classFile.delete() failed
org.apache.jasper.JasperException: Unable to compile class for JSP
*
*
*
*
*
We don't precompile the jsps. The related jsps already have the
corresponding .java and .class files in the work folder.

Have researched and found a ton of solution for similar issues with earlier
versions of tomcat. Have tried the following plausible solutions:
1. Made sure that the tomcat install was clean, the work folder was deleted
2. Made sure tomcat has full permissions to the appropriate File/Folders
3. Made sure tomcat is running with development=false
4. Tried with JspServlet setting of fork=true and fork=false
5. Made sure that there's no search/indexing services trying to access
tomcat folders creating access conflict
6. Tried going to the latest version of tomcat 7.0.27

The error still persists. Any thoughts/ideas ...
thanks.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message