tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dhaval Jaiswal <dhaval.jais...@via.com>
Subject SEVERE: Unable to start cluster.
Date Wed, 04 Apr 2012 14:40:49 GMT
Hi List,

Below is the error we are facing while starting tomcats.

SEVERE: Unable to start cluster.
org.apache.catalina.tribes.ChannelException: java.net.SocketException: Not
a multicast address; No faulty members identified.


Our cluster setting is as below in server.xml


 <Cluster className="org.apache.catalina.ha.tcp.SimpleTcpCluster"
channelSendOptions="6">
        <Manager className="org.apache.catalina.ha.session.BackupManager"
expireSessionsOnShutdown="false"
                   notifyListenersOnReplication="true" mapSendOptions="6"/>

            <Channel
className="org.apache.catalina.tribes.group.GroupChannel">
             <Membership
className="org.apache.catalina.tribes.membership.McastService"
                        address="192.168.3.14"
                        port="45564"
                        frequency="500"
                        dropTime="30000"/>
             <Receiver
className="org.apache.catalina.tribes.transport.nio.NioReceiver"
                      address="auto"
                      port="4000"
                      selectorTimeout="5000"
                      timeout="60000"
                      maxThreads="6"/>

             <Sender
className="org.apache.catalina.tribes.transport.ReplicationTransmitter">
                  <Transport
className="org.apache.catalina.tribes.transport.nio.PooledParallelSender"
timeout="60000" keepAliveCount="0"/>
             </Sender>
             <Interceptor
className="org.apache.catalina.tribes.group.interceptors.TcpFailureDetector"/>
             <Interceptor
className="org.apache.catalina.tribes.group.interceptors.MessageDispatch15Interceptor"/>
             <Interceptor
className="org.apache.catalina.tribes.group.interceptors.ThroughputInterceptor"/>
           </Channel>
         <Valve className="org.apache.catalina.ha.tcp.ReplicationValve"

filter=".*\.gif|.*\.js|.*\.jpeg|.*\.jpg|.*\.png|.*\.htm|.*\.html|.*\.css|.*\.txt"/>
         <Valve
className="org.apache.catalina.ha.session.JvmRouteBinderValve"/>
       <ClusterListener
className="org.apache.catalina.ha.session.ClusterSessionListener"/>
       <ClusterListener
className="org.apache.catalina.ha.session.JvmRouteSessionIDBinderListener"/>
     </Cluster>



Note: 192.168.3.14 is the IP of backup manager with java & 192.168.3.9 is
the IP address of local tomcat where above server.xml is hosted.

Please guide us as to how to overcome the issue & please give us the sample
<cluster>   </cluster>  file if possible.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message