tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Wahler <>
Subject Tomcat 5.5 JDK version compatibility
Date Thu, 08 Mar 2012 18:49:48 GMT
Hi all, I have a question about a comment on this bug report:

Mark Thomas noted that:

"The application can not be compiled using a 1.4 JDK (the minimum Java version
required by Servlet 2.4) since it uses annotations. While applications may be
compiled with a later Java version, they must be compilable with the minimum
Java version."

I just want to make sure I'm understanding this correctly. Does this
mean that if a web application is deployed in Tomcat 5.5, it may not
use any language features that were introduced in J2SE 5.0 or later
(e.g. annotations and generics), even if those features are supported
by the JRE? I looked through both the servlet 2.4 specification and
Tomcat's documentation and couldn't find anywhere this was documented,
but I may have missed something.

-- David

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message