tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Samad - Yieldbroker <Alex.Sa...@yieldbroker.com>
Subject RE: Issues with the tomcat connector (On W2k8 + IIS7.5)
Date Wed, 14 Mar 2012 22:40:04 GMT


> -----Original Message-----
> From: Mladen Turk [mailto:mturk@apache.org]
> Sent: Tuesday, 13 March 2012 5:01 PM
> To: users@tomcat.apache.org
> Subject: Re: Issues with the tomcat connector (On W2k8 + IIS7.5)
> 
> On 03/13/2012 12:09 AM, Alex Samad - Yieldbroker wrote:
> > [snip]
> >>
> >> Try the RC binaries from
> >> http://people.apache.org/~mturk/tomcat-connectors/jk-1.2.33/
> >>
> >> Does this one crashes as well?
> >
> > Okay, got your build from there.
> >
> > 1) it loads up with single application thread (so not a web garden)
> > but then failed
> 
> OK, cool.
> 
> > 2) I tried it as a web garden, so 4 processes failed bad !!!
> >
> 
> Suppose the previous versions do the same.

32 didn't fail as bad as this

> 
> > This is what I see in the event log
> > ERROR-
> > Faulting application name: w3wp.exe, version: 7.5.7601.17514, time
> > stamp: 0x4ce7afa2 Faulting module name: isapi_redirect.dll, version:
> > 1.2.33.0, time stamp: 0x4f59bc9e Exception code: 0xc0000005 Fault
> > offset: 0x0000000000039e82
> 
> This looks like referencing null memory.
> Is there anything in the jk.log before that if you turn log level to trace?

Okay I ran it on trace ... died, the application pool died !

The files are rather large, I will email directly to you instead of on list (1M + 25k)

> 
> > Faulting process id: 0x154c
> > Faulting application start time: 0x01cd00a34e76bf11 Faulting
> > application path: c:\windows\system32\inetsrv\w3wp.exe
> > Faulting module path:
> > C:\YB\Shared\dev.yieldbroker.com\ajpconfig\isapi_redirect.dll
> > Report Id: 8ded0aa6-6c96-11e1-a357-005056b7000a
> >
> 
> > Bit more curious as to why my build didn't work
> >
> > I have VS 2010 install,
> > I built first with 32bit to get the programme built Then I opened a
> > Win64 command window and build the dll there. Mine is about 100K
> small, so I am guessing I am missing something ...
> >
> 
> I build that using WinDDK so it links to msvcrt.dll instead msvcrtXXX.dll.
> Anyhow suppose you missed something with win32/win64 environment
> settings.
> 
> Try to build directly from 1.2.33-src.zip I fixed the need to run win32 build
> before win64 so you can build 64-bit directly.
> Tested that with vs2010 and it builds flawlessly.

Just went in and did a nmake (what is WinDDK and should I install it ?)

C:\Users\alex.samad\Documents\SVN\Tomcat-Connector\tomcat-connectors-1.2.33-src\tomcat-connectors-1.2.33-src\native\iis>nmake
-f Makefile.am
d64

Microsoft (R) Program Maintenance Utility Version 10.00.30319.01
Copyright (C) Microsoft Corporation.  All rights reserved.

        cd ".\pcre"
        "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\BIN\amd64\nmake.exe" /   
               /F ".\pcre.amd64"

Microsoft (R) Program Maintenance Utility Version 10.00.30319.01
Copyright (C) Microsoft Corporation.  All rights reserved.

        if not exist ".\Release_amd64/" mkdir ".\Release_amd64"
        tempfile.bat
.\pcre.amd64(142) : fatal error U1054: cannot create inline file 'tempfile.bat'
Stop.
NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\BIN\amd64\nmake.exe"'
: return code '0x2'
Stop.

> 
> 
> Regards
> --
> ^TM
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message