tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: Service Temporaily Unavailbale Message and tomcat servers starts responding without a restart after few mins
Date Thu, 08 Mar 2012 14:46:17 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

André,

On 3/8/12 4:17 AM, André Warnier wrote:
> Amol Puglia wrote:
>> Hi,
>> 
>> Thanks for the response.
>> 
>> I am having mod_proxy_balancer as a balancer and having apache
>> version 2.2.16.
>> 
>> I can not used tomcat 6.0.35 because my application eMatrix does
>> not support that version.
>> 
> I do not know eMatrix, but on the face of it, that sounds very
> strange. A java application should not be sensitive to a
> sub-release version of Tomcat 6.0. And you should be able to update
> Tomcat from 6.0.26 to 6.0.35 in-place, without even telling your
> application about it. What exactly prevents you from doing that ?

+1

On the other hand, it's always a good idea to use a supported version
of whatever your software is: you don't want the vendor blaming
everything on Tomcat.

But, the OP should tell eMatrix that 6.0.26 is no longer appropriate
for production use given the security vulnerabilities that have been
fixed since then: http://tomcat.apache.org/security-6.html

They need to re-certify their app for a recent version of Tomcat.

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG/MacGPG2 v2.0.17 (Darwin)
Comment: GPGTools - http://gpgtools.org
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk9YxjkACgkQ9CaO5/Lv0PAYTQCfW5OXSqAvbfGmjMIPJYLY4eCj
LP0AnAufV/Two4A5pYjZMKsKxXbA2H4F
=GK9x
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message