tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Preißer <verlag.preis...@t-online.de>
Subject IIS 7.0 Worker process crashes on App Pool recycling since ISAPI redirector 1.2.33
Date Fri, 16 Mar 2012 15:27:54 GMT
Hi all,

I have a system with Windows Server 2008 32 bit, IIS 7.0, Java 1.7.0_03, Tomcat 7.0.26 and
the ISAPI redirector.

Since I updated the ISAPI redirector from 1.2.32 to 1.2.33, it seems that each time when IIS
tries to recycle its application pool, the IIS worker process (w3wp.exe) crashes in isapi_redirect.dll.
In the event log, an "Application Error" of w3wp.exe is logged (here is an English translation):

Faulty application w3wp.exe, Version 7.0.6002.18005, time stamp 0x49e023cf, faulty module
isapi_redirect.dll, Version 1.2.33.0, time stamp 0x4f59be7d, exception code 0xc0000005, error
offset 0x0002bb16, process ID 0x10f0, application start time 01cd0336e5b7824a.
(The process ID does not match the one of w3wp.exe before the crash, nor the one after the
crash, so it seems a bit like when the new w3wp.exe is launched after recycle, it crashes
and immediately another w3wp.exe is started).


In the ISAPI log, following lines appear when w3wp.exe crashes:
[Fri Mar 16 06:37:38.402 2012] [4336:6828] [error] ajp_worker_factory::jk_ajp_common.c (3006):
allocating ajp worker record from shared memory
[Fri Mar 16 06:37:38.417 2012] [4336:6828] [error] wc_create_worker::jk_worker.c (150): factory
for ajp13 failed for worker1
[Fri Mar 16 06:37:38.426 2012] [4336:6828] [error] build_worker_map::jk_worker.c (261): failed
to create worker worker1
[Fri Mar 16 06:37:38.434 2012] [4336:6828] [error] extension_fix::jk_uri_worker_map.c (554):
Could not find worker with name 'worker1' in uri map post processing.

Any idea what these lines could mean / that caused them? Note that it seems that after the
crash (when a new w3wp.exe is created), pages are served fine again (though I do not know
what happens with request that are made exactly in the time when IIS resets the app pool).
The crashes and these log lines didn't appear in ISAPI 1.2.32.

I think I read somewhere in the thread "Issues with the tomcat connector (On W2k8 + IIS7.5)"
about some change in the ISAPI connector which has to do with shared memory, but I'm not sure.

Thanks!


Regards,
Konstantin Preißer


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message