tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Tomcat with mod_jk becomes irresponsive after working for awhile
Date Wed, 22 Feb 2012 20:47:23 GMT
Ofer Israeli wrote:
> All,
> 
> I have a deployment on Windows 2003 Server using Apache 2.2.16, Tomcat 5.5.30 and mod_jk
1.2.31. Apache and Tomcat reside on the same machine. The communication is fine for days /
weeks, but at some point all requests to the server (to Apache) that use mod_jk return HTTP
503.
> The error that shows up in mod_jk.log is:
> [Mon Feb 20 12:07:01.464 2012] [7280:6912] [error] ajp_send_request::jk_ajp_common.c
(1610): (all) failed sending request on a fresh connection (recoverable), socket -1 (errno=54)
> [Mon Feb 20 12:07:01.464 2012] [7280:6912] [error] ajp_service::jk_ajp_common.c (2562):
(all) connecting to tomcat failed.
> 
> I've done a packet capture and I see that Apache initiates the 3-way handshake with Tomcat
which looks fine and immediately after the connection is established, Tomcat sends a FIN packet
to Apache whereby both sides gracefully close the connection.
> 
> Have any of you encountered this before?
> 
> Do you have any idea what debug logs I can turn on to get further information without
bringing down the server so that we don't loose this situation?
> 
> 
Hi.
It sounds unlikely that you would have done a permanent packet capture during days/weeks,

just waiting for this to happen.  So what made you decide when to start your packet 
capture, or how do you force the problem to happen when you have started your packet capture
?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message