tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: mod_jk doesn't map to software-generated web address, but maps to this address when I enter it into browser
Date Thu, 16 Feb 2012 17:17:29 GMT
Ok, that's a lot more readable.
See in-line.

modjklist@comcast.net wrote:

(removing the irrelevant bits)

...
> 
> http://mydomain.com:8080/mywebapp 
> 
> the Adobe Flashbuilder software states that a connection was successfully made to the
server. However, if I enter the following instead: 
> 

As Chris was saying, that shows that at least your webapp is reachable when connecting to

Tomcat directly.


> 
> Later in this log snippet , you'll see an entry for attempting to map URI ' /jitterapp/flex_wizard_...
Here's that line: 
> 

So what "/jitterapp" now doing here ?  I thought it was "/mywebapp" ?

(It's ok to edit configs and logfiles, but if you forget some lines, then it gets kind of

confusing).

...
> 
> NameVirtualHost 67.227.243.196:80 
> NameVirtualHost * 
> ... 
> <VirtualHost xx.xxx.xxx.196:80> 

That's also kind of confusing.
Why not just

NameVirtualHost *

and

<VirtualHost *>

?

> JkMountCopy On 

There is no point to that one, since you have no JkMounts in nyour main server config.
Remove it, it may interfere later.


> JkMount /mywebapp/* worker1 
> JkMount /mywebapp worker1 

ok.

> </VirtualHost> 
> 
> ------workers.properties file----------
> 
> The workers.properties file is: 
> 
> worker.list=worker1 
> worker.worker1.type=ajp13 
> worker.worker1.host=localhost 
> worker.worker1.port=8009 
> 

ok also.

> ------------mod_jk.log file snippet---------- 
> 
> [Thu Feb 16 06:46:37 2012] [13722:140020322740160] [debug] jk_handler::mod_jk.c (2662):
Service finished with status=404 for worker=worker1 
> 
> [Thu Feb 16 06:47:35 2012] [13723:140020322740160] [debug] jk_translate::mod_jk.c (3488):
missing uri map for host3.mydomain.com:/mywebapp/flex_wizard_project_test_script_server_550713325917236076.htm

> 
> [Thu Feb 16 06:47:35 2012] [13723:140020322740160] [debug] jk_map_to_storage::mod_jk.c
(3647): missing uri map for host3.mydomain.com:/mywebapp/flex_wizard_project_test_script_server_550713325917236076.htm

> 
> [Thu Feb 16 06:47:35 2012] [13723:140020322740160] [debug] jk_translate::mod_jk.c (3488):
missing uri map for host3.mydomain.com:/404.shtml 
> 
> [Thu Feb 16 06:47:35 2012] [13723:140020322740160] [debug] jk_map_to_storage::mod_jk.c
(3647): missing uri map for host3.mydomain.com:/404.shtml 
> 
> [Thu Feb 16 06:47:35 2012] [13723:140020322740160] [debug] jk_translate::mod_jk.c (3488):
missing uri map for host3.mydomain.com:/cp_errordocument.shtml 
> 
> [Thu Feb 16 06:47:35 2012] [13723:140020322740160] [debug] jk_map_to_storage::mod_jk.c
(3647): missing uri map for host3.mydomain.com:/cp_errordocument.shtml 
> 
> [Thu Feb 16 06:49:46 2012] [13724:140020322740160] [debug] jk_translate::mod_jk.c (3488):
missing uri map for host3.mydomain.com:/ 
> 
> [Thu Feb 16 06:49:46 2012] [13724:140020322740160] [debug] jk_map_to_storage::mod_jk.c
(3647): missing uri map for host3.mydomain.com:/ 
> 
> [Thu Feb 16 06:49:46 2012] [13724:140020322740160] [debug] jk_translate::mod_jk.c (3488):
missing uri map for host3.mydomain.com:/index.html.var 
> 
> ... 

All of the above are confusing, as they are probably from your orevious attempts.

> 
> [Thu Feb 16 06:55:02 2012] [13724:140020322740160] [debug] jk_translate::mod_jk.c (3488):
missing uri map for host3.mydomain.com:/whm-server-status 
> 
> [Thu Feb 16 06:55:02 2012] [13724:140020322740160] [debug] jk_map_to_storage::mod_jk.c
(3647): missing uri map for host3.mydomain.com:/whm-server-status 
> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] map_uri_to_worker_ext::jk_uri_worker_map.c
(1036): Attempting to map URI '/mywebapp/flex_wizard_project_test_script_server_550713325917236076.htm'
from 6 maps 
> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] find_match::jk_uri_worker_map.c
(850): Attempting to map context URI '/glassfish-test/*=worker1' source 'JkMount'

Aha. So there are JkMount's which you have not told us about...


> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] find_match::jk_uri_worker_map.c
(850): Attempting to map context URI '/mywebapp/*=worker1' source 'JkMount' 
> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] find_match::jk_uri_worker_map.c
(863): Found a wildchar match '/mywebapp/*=worker1'

There we go.  It has found a match, according to your JkMount's.

> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] jk_handler::mod_jk.c (2522):
Into handler jakarta-servlet worker=worker1 r->proxyreq=0 
> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] wc_get_worker_for_name::jk_worker.c
(116): found a worker worker1 
> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] wc_maintain::jk_worker.c (339):
Maintaining worker worker1 
> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] wc_get_name_for_type::jk_worker.c
(293): Found worker type 'ajp13' 
> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] init_ws_service::mod_jk.c
(1024): Service protocol=HTTP/1.1 method=GET ssl=false host=(null) addr=xx.xx.xxx.163 name=mydomain.com
port=80 auth=(null) user=(null) laddr=xx.xxx.xxx.196 
> 
> raddr=xx.xxx.xxx.163 uri=/mywebapp/flex_wizard_project_test_script_server_550713325917236076.htm

> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] ajp_get_endpoint::jk_ajp_common.c
(3161): acquired connection pool slot=0 after 0 retries 
> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] ajp_marshal_into_msgb::jk_ajp_common.c
(647): ajp marshaling done 
> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] ajp_service::jk_ajp_common.c
(2440): processing worker1 with 2 retries 
> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] ajp_send_request::jk_ajp_common.c
(1624): (worker1) all endpoints are disconnected. 
> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] jk_open_socket::jk_connect.c
(484): socket TCP_NODELAY set to On 
> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] jk_open_socket::jk_connect.c
(608): trying to connect socket 23 to 127.0.0.1:8009 
> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] jk_open_socket::jk_connect.c
(634): socket 23 [127.0.0.1:40539 -> 127.0.0.1:8009] connected 
> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] ajp_connection_tcp_send_message::jk_ajp_common.c
(1195): sending to ajp13 pos=4 len=450 max=8192 
> 
> [Thu Feb 16 06:55:21 2012] [13725:140020322740160] [debug] ajp_connection_tcp_send_message::jk_ajp_common.c
(1195): 0000 12 34 01 BE 02 02 00 08 48 54 54 50 2F 31 2E 31 - .4......HTTP/1.1 
> 

And all of the above show that it is passing this request to Tomcat.
So either we are missing the end of the story, or else what is your problem ?

In other words, what happens next ?


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message