tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jess Holle <je...@ptc.com>
Subject Re: Form Authentication POST data not preserved?
Date Sat, 04 Feb 2012 23:49:10 GMT
Yes, I'm using Tomcat authentication.  Yes, the issue is after 
authentication on the POST retry.

On 2/4/2012 12:27 PM, Christopher Schultz wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Jess,
>
> On 2/3/12 5:59 PM, Jess Holle wrote:
>> Or could this be getting loused up by having a servlet request
>> filter that calls getParameterMap() first thing?
>>
>> I'd *assume* not -- as that would be pretty hokey...
> Probably not: Tomcat's valves (including the one that performs
> authentication) all fire before any of the webapp-specified filters
> run. In any case, the problem you observe is *after* authentication
> when the POST should be re-tried, right?
>
> Silly question: you *are* using Tomcat's authentication, right? I
> mean, if you're using something else like ACEGI (does that even still
> exist -- other than as Spring Security?) then you'll have to look
> somewhere else.
>
> - -chris
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG/MacGPG2 v2.0.17 (Darwin)
> Comment: GPGTools - http://gpgtools.org
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
>
> iEYEARECAAYFAk8teKEACgkQ9CaO5/Lv0PAmYwCeI0qfe5iNv/8X3z3eN4PyKtm1
> 6YYAoKteM140ZuIVbr9e01IP9aZf+rZq
> =aUyr
> -----END PGP SIGNATURE-----
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message