tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jess Holle <je...@ptc.com>
Subject Re: Form Authentication POST data not preserved?
Date Fri, 03 Feb 2012 22:53:14 GMT
In case this makes any difference this is with the AJP BIO connector.

On 2/3/2012 4:51 PM, Jess Holle wrote:
> I posted a query recently wherein I thought that POST data was being 
> lost *only* if the user had been authenticated, their session timed 
> out, and then they POST'ed to a URL requiring authentication -- thus 
> having their request interrupted for a form-based login.
>
> I know Tomcat is supposed to preserve the POST data in this case as 
> well as in the case where one had not yet authenticated prior to the 
> POST, but I'd thought that the latter case worked.
>
> As someone nicely pointed out, that makes no sense.
>
> So here's the issue:
>
> Neither case works.  My POST data is always lost here.  I've tried 
> various values of maxSavePostSize, including leaving it unspecified -- 
> to no avail.  [I had it set to -1 and maxPostSize also set to -1, 
> which I also tried leaving unspecified.]
>
> I've tried various things -- all with no luck.
>
> This is with Tomcat 7.0.23.  I'm pretty sure I was having similar 
> issues with 7.0.25 as well.  [No, I didn't really downgrade -- I'm 
> just working in a context that's still using 7.0.23 at the moment.]
>
> I'm left wondering what could be causing the issue.
>
> -- 
> Jess Holle
>
> P.S. The lack of wisdom of setting maxSavePostSize is clear enough to 
> me now.  I'll be setting this to a large but still not egregious value 
> once I figure out the rest of this...


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message