tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Larose <Justin.Lar...@nexweb.org>
Subject Re: SSL Configuration Errors
Date Mon, 09 Jan 2012 19:40:49 GMT
Chris,

> This list strips non-text attachments.

I will sent it in text format next time.

> > I have used the keytool to delete all 3 certs (root, intermediate
> > and primary) and readd them many times. I even just tried only the
> > Primary cert with the alias tomcat as the only cert. But the log
> > shows same error:
> >
> > SEVERE: Failed to initialize end point associated with
> > ProtocolHandler ["http-bio-8443"] java.io.IOException: Alias name
> > tomcat does not identify a key entry

> When you created your key to create the CSR, did you use "tomcat" as
> the alias for *that* as well?

> Looks like it can't find a *key*, not a *cert*.

I was just looking at that. When I had the 2 "list" entries and the error 
log side by side I noticed the error says, "Alias name tomcat does not 
identify a key entry"
And when I look at the self signed cert it is listed as a 
"PrivateKeyEntry" but on my imported cert it is listed as a 
"trustedCertEntry"

This seems to be the problem. How do I set my imported cert as a "key 
entry" or get Tomcat to read it as a CertEntry?

Thanks,
Justin
******************************************************************************
This email and any files transmitted with it are intended solely for 
the use of the individual or agency to whom they are addressed. 
If you have received this email in error please notify the Navy 
Exchange Service Command e-mail administrator. This footnote 
also confirms that this email message has been scanned for the
presence of computer viruses.

Thank You!            
******************************************************************************


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message