tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Is SSL keystore with AJP connector possible?
Date Thu, 19 Jan 2012 13:51:51 GMT
mandg wrote:
> Well, there is the AJP connector but I gather that shouldn't matter - here's
> the full server.xml:
> 
> <?xml version='1.0' encoding='utf-8'?>
> 
> 
> <Server port="8005" shutdown="SHUTDOWN">
> 
>   
>   <Listener className="org.apache.catalina.core.AprLifecycleListener"
> SSLEngine="on" />
>   
>   <Listener className="org.apache.catalina.core.JasperListener" />
>   
>   <Listener
> className="org.apache.catalina.core.JreMemoryLeakPreventionListener" />
>   
>   <Listener className="org.apache.catalina.mbeans.ServerLifecycleListener"
> />
>   <Listener
> className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener" />
> 
>   
>   <GlobalNamingResources>
>     
>     <Resource name="UserDatabase" auth="Container"
>               type="org.apache.catalina.UserDatabase"
>               description="User database that can be updated and saved"
>               factory="org.apache.catalina.users.MemoryUserDatabaseFactory"
>               pathname="conf/tomcat-users.xml" />
>   </GlobalNamingResources>
> 
>   
>   <Service name="Catalina">
>   
>     
>     
>     
>     
>     
>     <Connector port="8080" protocol="HTTP/1.1" 
>                connectionTimeout="20000" 
>                redirectPort="8443" />
>     
>                
> 	
> 	<Connector 
>            port="8443" maxThreads="200"
>            scheme="https" secure="true" SSLEnabled="true"
>            SSLCertificateFile="$CATALINA_HOME/webapps/keystore/hpsmprod.crt" 
>           
> SSLCertificateKeyFile="$CATALINA_HOME/webapps/keystore/hpsmprod.pem"
>            clientAuth="false" SSLProtocol="TLSv1"/>
> 
>     
>     <Connector port="8009" protocol="AJP/1.3" redirectPort="8443" />
> 
>     
> 
>      
>     <Engine name="Catalina" defaultHost="localhost">
> 
>       
>               
> 
>       
>       
> 
>       
>       <Realm className="org.apache.catalina.realm.UserDatabaseRealm"
>              resourceName="UserDatabase"/>
> 
>       
>       <Host name="localhost"  appBase="webapps"
>             unpackWARs="true" autoDeploy="true"
>             xmlValidation="false" xmlNamespaceAware="false">
> 
>         
>         
> 
>         
>         
> 
>       </Host>
>     </Engine>
>   </Service>
> </Server>
> 
> 
> --

You are right, it does not /look/ like you have two Tomcat Connector's trying to listen on

the same port 8443.
The error message is quite explicit about the error however, and it usually does not lie.
So something does not fit.

My guess at this point is that you /do/ have something else which opens port 8443, and you

just overlooked it.
I can't prove that though, since you are on your machine and I am not.



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message