tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: [OT] JDK Version Mismatch
Date Wed, 18 Jan 2012 21:23:01 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

deniz,

(Marking OT because this has nothing to do with Tomcat)

On 1/13/12 2:25 AM, deniz wrote:
> I have created and compiled my class files with jdk 1.7 and then
> put them in a jar and included that jar file in my webapp project
> on jdk 1.6 which i create jsp files. is this a feasible way to fix
> the problem?

When compiling, use whatever your compiler's version of the "-target"
parameter for javac: you can target a particular (older) JVM and your
class files will be readable by them.

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG/MacGPG2 v2.0.17 (Darwin)
Comment: GPGTools - http://gpgtools.org
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk8XODUACgkQ9CaO5/Lv0PCONwCgnfMih1JSvXvhcR1oCtkaiUJk
bNYAn1UiXt0xV037JP096reWQM1W9GaL
=O0b4
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message