tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gnath <gautam_exquis...@yahoo.com>
Subject Re: Tomcat 6.0.35 -crossing maxThreads configured count
Date Mon, 23 Jan 2012 14:43:47 GMT


Please ignore my previously sent edited configuration. Here is what our configurations are
without editing them :

<Executor name="tomcatThreadPool"
                  namePrefix="catalina-exec-"
                  maxThreads="500"
                  minSpareThreads="50"/>

    <Connector enableLookups="false" executor="tomcatThreadPool"  port="40080"
 protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="40443" address="192.42.24.40"/>

    <Connector enableLookups="false" executor="tomcatThreadPool"  port="40443" protocol="HTTP/1.1"
SSLEnabled="true"
               scheme="https" secure="true"
               clientAuth="false" sslProtocol="TLS" address="192.42.24.40"
               keystoreFile="/usr/bin/keystore" keystorePass="password" />

Please let me know. I appreciate your help in looking into this

Thanks
G




________________________________
 From: André Warnier <aw@ice-sa.com>
To: Tomcat Users List <users@tomcat.apache.org> 
Sent: Monday, January 23, 2012 6:37 AM
Subject: Re: Tomcat 6.0.35 -crossing maxThreads configured count
 
gnath wrote:
> 
> Hi Andre, 
> Sorry, my mistake. 
> 
> you are right. i actually meant milliseconds. However i checked my configuration again
and here is what i have :  ( I have the http connector configured at 20000 ms. and the secured
one left at default 60000 ms)
> 
> 
> <Executor name="tomcatThreadPool"
>                   namePrefix="catalina-exec-"
>                   maxThreads="500"
>                   minSpareThreads="50"/>
> 
>     <Connector enableLookups="false" executor="tomcatThreadPool"  port="http port"
>  protocol="HTTP/1.1"
>                connectionTimeout="20000"
>                redirectPort="https port" address="ip address"/>
> 
>     <Connector enableLookups="false" executor="tomcatThreadPool"  port="http port"
protocol="HTTP/1.1" SSLEnabled="true"
>                scheme="https" secure="true"
>                clientAuth="false" sslProtocol="TLS" address="ip address"
>                keystoreFile="path to cert" keystorePass="password" />
> 
> 
> Please let me know if im doing any mistake or missing anything here.
> 
On the face of it, you are, or you are prone to typos.
Assuming that when you indicate "http port" above, you mean that this is in reality some consistent
specific valid port number, then at least one of them is wrong.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message