tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From deniz <>
Subject JDK Version Mismatch
Date Fri, 13 Jan 2012 05:26:53 GMT
Hi All,

I have a problem with tomcat 6.0.35. Basically I am getting this error each
time I try to access my webapp from the browser:

org.apache.jasper.JasperException: javax.servlet.ServletException:
java.lang.UnsupportedClassVersionError: xxx/xxx/xxxManager : Unsupported
major.minor version 51.0 (unable to load class

The machine on which tomcat runs, uses jdk 1.7. And while creating my war
file on eclipse, it uses jdk 1.6. I made some search on other places and
found out that this version mismatch is the reason. However, there is no
java ee 7, so i cant create my war file with the new version, by using

my question: is there any other way to overcome this issue with tomcat? or i
have to install java 1.6 to the machine that i run tomcat?

thank you in advance, for your helps 

View this message in context:
Sent from the Tomcat - User mailing list archive at

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message