tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Tomcat 7 Valve not logging correct response size
Date Mon, 05 Dec 2011 07:29:47 GMT
2011/12/5 Antonios Kogias <coyas@hua.gr>:
> Good morning,
>
>  I'm using Tomcat 7.0.16 and a Valve in the server.xml file that uses the %B
> option to log the "Bytes sent, excluding HTTP headers"
> (http://tomcat.apache.org/tomcat-7.0-doc/config/valve.html).
>
> <Valve className="org.apache.catalina.valves.AccessLogValve"
> directory="logs"
>               prefix="localhost_access_log." suffix=".txt"
>               pattern="%H %p %m %D %s %B %a %t &quot;%r&quot;"
> resolveHosts="false"/>
>
> This works correctly for small response size (up to 30-40 kB), but for
> bigger sizes it doesn't; it only writes zero as response size in the web
> access log (I have tested that with 100 kB and 1000 kB static files).
>
> Any idea why is that happening and what can be done to overcome?
>
> Antonios
>
> PS. OS is MS Windows XP 32bit SP3

1. What happens with 7.0.23?
2. Are you sure that the file was delivered to the client? Was the
time taken to process the request greater than zero? Was ir response
200 OK, or 304 Not modified? In the latter case the file is not sent,
because the clint already has a copy of it.
3. What connectors are you using and what are their settings?

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message