tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Tomcat 5.5 crashes after changing server IP
Date Mon, 12 Dec 2011 12:02:04 GMT
sirwiz@8host.pl wrote:
>>> It is probly Tomcat + Xen (KVM) + Intel (?) releted problem.
>>
>> I really have no idea how you come to that conclusion.
> 
> Like i said when i install Windows 8 on Xen machine, starts Virtuabox on 
> it and new 32bit Centos, tomcat and my api works perfectly. It was 
> running for a 2 years on AMD procesor (with the same config files) and 
> it works like charm also. Problem starts when we switch to new Intel 
> machine. I also try to install the same version of xen on AMD server and 
> it works, that only dont work on xen or kvm. Also i dowload whole Xen 
> disk image and run it on different intel procesor on virtuabox (Windoiws 
> 7) and the same error. Its realy strange situation when i have to 
> virtualize 2 systems to make it work ;). When i convert working 
> virtuabox machine to Xen image, i have the same error.

It seems really unclear what all of this has to do with Tomcat.
Tomcat is Java code. It runs under a JVM, and uses that JVM's code for anything to do with

the interface to the underlying OS or hardware.  So it should not make an iota of 
difference to Tomcat under which OS and machine it is running.
On the other hand, the /JVM/ which you are using may have problems, but again that has 
nothing to do fundamentally with Tomcat.

> 
> 
>>> I install
>>> tomcat from 5 to 7 on diferent VPS's, always have the same result but
>>> always i have Xen or KVM and Intel CPU, old serwer has AMD cpu and all
>>> works great (and some older version of Xen also), but on new Xen or KVM
>>> based VPS i always have the same problem. But when i run XEN machine
>>> with Windows 8 and run on it VirtuaBox and starts new 32 bit CentOS all
>>> work great (but i have virtualization on virtualized machine ;) ). Its
>>> realy strange problem, and have no idea how to solve it.
>>
>> Fix one thing at a time.  Start with your config.
> 
> It was log from "oryginal" Tomcat instalation, on new install we have 
> only AJP stops and Memory Leak.
> 

Then provide the new log, or do you just want us to keep guessing ?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message