tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Kerber <dcker...@verizon.net>
Subject Re: Anybody can help me?Thank you!
Date Sat, 03 Dec 2011 14:22:54 GMT
On 12/3/2011 8:57 AM, ?? wrote:
> Hi,you can read message in attachment.
> 1.
> "
> and the error message mean '
> 2011-12-02 07:45:52,654 [catalina-exec- 
> 7] ERROR [net.bwda.framework.web.indexpage.IndexpagesAction.ssoLogin(IndexpagesAction.java:357)]
- ? 
> ?????(translate: sso login 
> failed)URL:http://10.33.211.35/ngcrm/aaaa/login.action?sessionId=753221&userCode=19500324&passwd=9519082&businessType=5&loginIp=1931feeb8738626ee32e20ac87243336

> <http://10.33.211.35/ngcrm/aaaa/login.action?sessionId=753221&userCode=19500324&passwd=9519082&businessType=5&loginIp=1931feeb8738626ee32e20ac87243336>
> ClientAbortException:  java.net.SocketException: ?????(translate:broken pipe.) 
> "
> 2.
> "So, you're saying that Tomcat isn't running but it is somehow still
> running? Can you be more specific? Why do you think it's running? Why
> do you think it's not running?"
> first why running? "ps -afe|grep java" i can see the pid is still there.
> second why not running? i use IE6 browser ,and i can't receive the 
> response message when i request the url.

Given those two, it's likely that tomcat is running, but your app is 
not, or is failing in some way when you connect to it.

D


> ------------------------------------------------------------------------
>
> ??
>
> ?????????????
>
> ??:??????????? ????????????10F
>
> Email: sunwen@bwda.net <mailto:sunwen@bwda.net>
>
> steven.sinclair.cn@gmail.com <mailto:steven.sinclair.cn@gmail.com>
>
> Mobile: 139 5188 5586
>
> *From:* Christopher Schultz <mailto:chris@christopherschultz.net>
> *Date:* 2011-12-03 00:52
> *To:* Tomcat Users List <mailto:users@tomcat.apache.org>
> *Subject:* Re: Anybody can help me?Thank you!
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> ??,
> On 12/2/11 11:20 AM, ?? wrote:
> > I use tomcat 7.0.22,when i use  getResponse().sendRedirect(url) in
> > action(Struts2 ),i watch tomcat log ,record this in following
> > picture.
> >
> > [java.net.SocketException]
> >
> > why?
> It could be many things: the error message itself is in Chinese, and
> it's in an image so there's no way for me to plug it into Google
> Translate to see what it actually says.
> My guess is that the client disconnected before you were able to send
> the redirect, and so there's nowhere for the data to go -- that would
> be a case where this exception is entirely expected and shouldn't be
> considered a problem.
> > and sometimes tomcat is not in service.but cpu \ memory and tomcat
> > thread is normal in solaris.
> So, you're saying that Tomcat isn't running but it is somehow still
> running? Can you be more specific? Why do you think it's running? Why
> do you think it's not running?
> By the way, you have code after your "sendRedirect" call that might
> affect the response -- that's probably a bad idea. Generally, you want
> "sendRedirect" to be the last thing your code does before returning
> from the doGet (or functionally-equivalent) method.
> - -chris
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG/MacGPG2 v2.0.17 (Darwin)
> Comment: GPGTools - http://gpgtools.org
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
> iEYEARECAAYFAk7ZAmUACgkQ9CaO5/Lv0PDfjACffipobj44hK2dJOcivFMO/ecL
> QPgAnAzLzhtFy8orswVBguQFi/xDrVCA
> =zYHj
> -----END PGP SIGNATURE-----
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message