tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 孙文 <sun...@bwda.net>
Subject Re: Re: Anybody can help me?Thank you!
Date Sat, 03 Dec 2011 13:57:50 GMT
Hi,you can read message in attachment. 

1.

"
and the error message mean '
2011-12-02 07:45:52,654 [catalina-exec-7] ERROR [net.bwda.framework.web.indexpage.IndexpagesAction.ssoLogin(IndexpagesAction.java:357)]
- 单点登录失败(translate: sso login failed)URL:http://10.33.211.35/ngcrm/aaaa/login.action?sessionId=753221&userCode=19500324&passwd=9519082&businessType=5&loginIp=1931feeb8738626ee32e20ac87243336
ClientAbortException:  java.net.SocketException: 打破的管道(translate:broken pipe.) "

2.
"So, you're saying that Tomcat isn't running but it is somehow still
running? Can you be more specific? Why do you think it's running? Why
do you think it's not running?"

first why running? "ps -afe|grep java" i can see the pid is still there. 

second why not running? i use IE6 browser ,and i can't receive the response message when i
request the url.



 



孙文
江苏保旺达软件技术有限公司
地址:   南京市浦口高新技术开发区中国南京留学人员创业园10F
Email:   sunwen@bwda.net
         steven.sinclair.cn@gmail.com 
Mobile: 139 5188 5586

From: Christopher Schultz
Date: 2011-12-03 00:52
To: Tomcat Users List
Subject: Re: Anybody can help me?Thank you!
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

孙文,

On 12/2/11 11:20 AM, 孙文 wrote:
> I use tomcat 7.0.22,when i use  getResponse().sendRedirect(url) in 
> action(Struts2 ),i watch tomcat log ,record this in following
> picture.
> 
> [java.net.SocketException]
> 
> why?

It could be many things: the error message itself is in Chinese, and
it's in an image so there's no way for me to plug it into Google
Translate to see what it actually says.

My guess is that the client disconnected before you were able to send
the redirect, and so there's nowhere for the data to go -- that would
be a case where this exception is entirely expected and shouldn't be
considered a problem.

> and sometimes tomcat is not in service.but cpu \ memory and tomcat 
> thread is normal in solaris.

So, you're saying that Tomcat isn't running but it is somehow still
running? Can you be more specific? Why do you think it's running? Why
do you think it's not running?

By the way, you have code after your "sendRedirect" call that might
affect the response -- that's probably a bad idea. Generally, you want
"sendRedirect" to be the last thing your code does before returning
from the doGet (or functionally-equivalent) method.

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG/MacGPG2 v2.0.17 (Darwin)
Comment: GPGTools - http://gpgtools.org
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk7ZAmUACgkQ9CaO5/Lv0PDfjACffipobj44hK2dJOcivFMO/ecL
QPgAnAzLzhtFy8orswVBguQFi/xDrVCA
=zYHj
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org
Mime
View raw message