tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Mikusa <dmik...@vmware.com>
Subject Re: SSL configuration on apache tomcat 6 - Oracle EL5
Date Tue, 06 Dec 2011 14:57:02 GMT
On Tue, 2011-12-06 at 06:50 -0800, Oladapo Moshood wrote:
> Thank you Daniel for your response. I do not see "libssl" listed, please
> see output:
> 
> [root@opt01 native]# ldd .libs/libtcnative-1.so
>         linux-gate.so.1 =>  (0x00b3b000)
>         libapr-1.so.0 => /usr/local/apr/lib/libapr-1.so.0 (0x00288000)
>         librt.so.1 => /lib/i686/nosegneg/librt.so.1 (0x00c83000)
>         libcrypt.so.1 => /lib/libcrypt.so.1 (0x00456000)
>         libpthread.so.0 => /lib/i686/nosegneg/libpthread.so.0 (0x00ec1000)
>         libdl.so.2 => /lib/libdl.so.2 (0x00bb6000)
>         libc.so.6 => /lib/i686/nosegneg/libc.so.6 (0x00110000)
>         /lib/ld-linux.so.2 (0x00941000)
> Can I still go-ahead and "make clean" then re-install the native?

Yes, try rebuilding with the "--with-ssl" option.  

Also, make sure that you have the openssl and openssl-dev (or whatever
your distro calls them) packages installed.

Dan


> Thank you.
> 
> On Tue, Dec 6, 2011 at 6:32 AM, Daniel Mikusa <dmikusa@vmware.com> wrote:
> 
> > On Mon, 2011-12-05 at 23:51 -0800, Oladapo Moshood wrote:
> > > Dan,
> > >
> > > This is what I actually have in my Oracle EL5. The other information I
> > sent
> > > on apache-tomcat-7 was done on my redhat 6 to see if the error i'm
> > getting
> > > is a bug in apache-tomcat-6, but got the same error.
> > >
> > > Here is how i installed it on Oracle EL5:
> > > I have the native libraries in
> > > /usr/share/apache-tomcat-6.0.20/bin/tomcat-native-1.1.22-src/jni/native
> > to
> > > install tomcat native.
> > >
> >
> > Please run "ldd .libs/libtcnative-1.so" and paste the output in here.
> > Do you see "libssl" listed in the output?
> >
> > > I Installed with "./configure --with-apr=/usr/local/apr-httpd/
> > > --with-java-home=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/"
> >
> > You might want to try the following:
> >
> > 1.) make clean
> > 2.) ./configure --with-apr=/usr/local/apr-httpd/
> > --with-java-home=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/ --with-ssl
> > 3.) make
> >
> > That will rebuild and while making sure that SSL is enabled.
> >
> > I'm not guaranteeing that will resolve the problem, but it's worth
> > verifying.
> >
> > Dan
> >
> >
> >
> > >
> > > Thank you
> > >
> > > On Mon, Dec 5, 2011 at 11:44 PM, Oladapo Moshood <morechud@gmail.com>
> > wrote:
> > >
> > > > Dear Dan,
> > > >
> > > > I have the native libraries in
> > > >
> > /usr/share/apache-tomcat-7.0.23/bin/tomcat-native-1.1.22-src/jni/native to
> > > > install tomcat native.
> > > >
> > > > I Installed with "./configure --with-apr=/usr/local/apr-httpd/
> > > > --with-java-home=/usr/java/jdk1.7.0/"
> > > >
> > > > Thank you
> > > >
> > > >
> > > >
> > > >
> > > > On Mon, Dec 5, 2011 at 2:23 PM, Daniel Mikusa <dmikusa@vmware.com>
> > wrote:
> > > >
> > > >> On Mon, 2011-12-05 at 13:20 -0800, Oladapo Moshood wrote:
> > > >> > Dear all,
> > > >> >
> > > >> > I have a very serious problem in making SSL work on apache tomcat
6
> > on
> > > >> my
> > > >> > oracle EL5. I have been able to configure everything. If I access
> > > >> > http://localhost:8443 it works but if I change the http to https,
> > it
> > > >> > doesn't work. I check my catalina.out log to see with and I saw:
> > > >> >
> > > >> > 5-Dec-2011 18:05:55 org.apache.catalina.core.AprLifecycleListener
> > > >> > lifecycleEvent
> > > >> > INFO: Failed to initialize the SSLEngine.
> > > >> >
> > > >> > I see no other error apart from this error. What can I do? I
need to
> > > >> > replicate this at a client site tomorrow - I have to make it
work.
> > > >> >
> > > >> >
> > > >> > I WILL REALLY APPRECIATE ANY ASSISTANCE.
> > > >> >
> > > >> > Thank you
> > > >>
> > > >> Using the APR connector requires native libraries.
> > > >>
> > > >> 1.) Where did you get the native libraries?  distro package or compile
> > > >> from source?
> > > >>
> > > >> 2.) What options were used to compile the libraries (i.e. if compiling
> > > >> from src, please list your "./configure ..." command).
> > > >>
> > > >> Dan
> > > >>
> > > >>
> > > >>
> > > >
> >
Mime
View raw message