tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan <ilario...@ksf.kiev.ua>
Subject Tomcat 7, JAX-WS 2.2.5
Date Mon, 14 Nov 2011 13:37:45 GMT
Dear All,

We are running JAX-WS web-services using JAX-WS RI under tomcat. First we
upgraded from Tomcat 5.5 to Tomcat 7 and everything was fine. Eventually, we
decided to upgrade to the latest JAX-WS RI and went for 2.2.5 version. 

We faced a problem. Upon requests we started seeing exceptions from JAX-WS
indicating that the body of the request was broken. From the point of view of
TCPMON everything was fine. We enabled request tracing and saw that the JAX-WS
RI was gettting empty requests' input streams which were causing mentioned
exceptions (org.jvnet.mimepull.MIMEParsingException: Missing start boundary;
com.ctc.wstx.exc.WstxEOFException: Unexpected EOF in prolog). 

Also, we tried tomcat 5.5 and JAX-WS RI 2.2.5 and they worked together fine.

After investigation we found out that all versions of JAX-WS RI since 2.2.2 were
causing the same problem. Presumably, the cause of the issue is servlet 3.0
async request processing which has been added in JAX-WS RI 2.2.2. Partly, it
explains why tomcat 5.5 works fine with JAX-WS RI 2.2.5 as the RI falls back to
non-async request processing.

We changed connector's protocol to 'org.apache.coyote.http11.Http11NioProtocol'
and everything started working.

As I understand, both BIO and NIO connectors should be working well with servet
3.0 async. Could you comment on this?

I am really looking forward to your reply.

Best regards,
Ivan


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message