tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bin Lan <lan...@gmail.com>
Subject Re: Set docBase in pom.xml for maven tomcat plugin
Date Wed, 02 Nov 2011 14:15:57 GMT
Hi Olivier,

I followed the instruction on
http://tomcat.apache.org/maven-plugin-2.0-SNAPSHOT/snapshot-test.html, and
use tomcat6:run instead of tomcat:run and now the plugin is using the path
in warSourceDirectory.

Quick question, is this gonna be part of the next release?

Thank you very much.

Regards
Bin



On Wed, Nov 2, 2011 at 7:32 AM, Olivier Lamy <olamy@apache.org> wrote:

> Can you try with last changes I have pushed ?
> You need to build locally from sources. (some network issues for
> *.apache.org so I cannot deploy snapshots)
>
> 2011/11/2 Bin Lan <lanbin@gmail.com>:
> > Forgot to mention that I am using 2.0-snapshot.
> > On Nov 2, 2011 7:20 AM, "Bin Lan" <lanbin@gmail.com> wrote:
> >
> >> Hi Olivier,
> >>
> >> Thank you for you reply. I run maven in cli not in ecclipse. Since the
> >> project is a eclipse native dynamc web project, so I gues eclipse has
> its
> >> own way to handle it. But regardless, the warSourceDirectory did not
> change
> >> the docBase for me.
> >>
> >> Regards
> >> Bin
> >> On Nov 2, 2011 5:08 AM, "Olivier Lamy" <olamy@apache.org> wrote:
> >>
> >>> Hello,
> >>> Yup that's the correct ml.
> >>> Did you try with last trunk version from ASF (tomcat6/7 mojos) ?
> >>> For how to test that: see
> >>> http://tomcat.apache.org/maven-plugin-2.0-SNAPSHOT/snapshot-test.html
> >>>
> >>> Yup normally warSourceDirectory should do the job.
> >>> Honestly I test more with cli (and not an eclipse user :-) ).
> >>> Do you have issues running that with cli ?
> >>>
> >>> 2011/11/2 Bin Lan <lanbin@gmail.com>:
> >>> > Hi all,
> >>> >
> >>> > I hope this message reaches the right user group. My question is
> pretty
> >>> > simple. In maven-tomcat-plugin, how can I set the docBase path?
> >>> Currently,
> >>> > my project is a Eclipse dynamic web project and all the webapp files
> are
> >>> > being stored inside ${basedir}/WebContent folder. Whenever I tried
> mvn
> >>> > tomcat:run, I got an IllegalArgumentException saying that the
> >>> > ${basedir}/src/main/webapp does not exists or is not readable. Is
> there
> >>> a
> >>> > way that I can set it inside pom.xml? I tried <warSourceDirectory>
> but
> >>> it
> >>> > is not doing what I want.
> >>> >
> >>> > Thanks in advance.
> >>> >
> >>> > Regards
> >>> > Bin
> >>> >
> >>>
> >>>
> >>>
> >>> --
> >>> Olivier Lamy
> >>> Talend : http://talend.com
> >>> http://twitter.com/olamy | http://linkedin.com/in/olamy
> >>>
> >>> ---------------------------------------------------------------------
> >>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> >>> For additional commands, e-mail: users-help@tomcat.apache.org
> >>>
> >>>
> >
>
>
>
> --
> Olivier Lamy
> Talend : http://talend.com
> http://twitter.com/olamy | http://linkedin.com/in/olamy
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message