tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Diedler <adied...@tecracer.de>
Subject Cluster - No faulty members identified
Date Fri, 04 Nov 2011 12:41:31 GMT
Hello @ll,

I have two Tomcat instances (6.0.32 x64 on Windows) on the same server. Both
servers make their own clustering with the other physical node independent
from each other on the same machine.

I get during start of the 2nd Tomcat on the same node the following error:

INFO: Receiver Server Socket bound to:/172.30.5.77:4001

04.11.2011 13:32:37 org.apache.catalina.tribes.membership.McastServiceImpl
setupSocket

INFO: Attempting to bind the multicast socket to /228.0.0.4:45574

04.11.2011 13:32:37 org.apache.catalina.tribes.membership.McastServiceImpl
setupSocket

INFO: Binding to multicast address, failed. Binding to port only.

04.11.2011 13:32:37 org.apache.catalina.tribes.membership.McastServiceImpl
setupSocket

INFO: Setting multihome multicast interface to:/178.30.5.77

04.11.2011 13:32:37 org.apache.catalina.ha.tcp.SimpleTcpCluster start

SCHWERWIEGEND: Unable to start cluster.

org.apache.catalina.tribes.ChannelException: java.net.SocketException: The
requested address is not valid in its context; No faulty members identified.

                

 

What could it be??

 

Here server.xml from the first tomcat:

[.]

<Engine name="Catalina" defaultHost="extranet" jvmRoute="worker2">

                               

                               <Cluster
className="org.apache.catalina.ha.tcp.SimpleTcpCluster"

                 channelSendOptions="8">

 

          <Manager className="org.apache.catalina.ha.session.DeltaManager"

                   expireSessionsOnShutdown="false"

                   notifyListenersOnReplication="true"/>

 

          <Channel
className="org.apache.catalina.tribes.group.GroupChannel">

            <Membership
className="org.apache.catalina.tribes.membership.McastService"

                        address="228.0.0.4"              

                        bind="172.30.5.77"


                        port="45564"

                        frequency="500"

                        dropTime="3000"/>

            <Receiver
className="org.apache.catalina.tribes.transport.nio.NioReceiver"

                      address="auto"

                      port="4000"

                      autoBind="100"

                      selectorTimeout="5000"

                      maxThreads="6"/>

 

            <Sender
className="org.apache.catalina.tribes.transport.ReplicationTransmitter">

              <Transport
className="org.apache.catalina.tribes.transport.nio.PooledParallelSender"/>

            </Sender>

            <Interceptor
className="org.apache.catalina.tribes.group.interceptors.TcpFailureDetector"
/>

            <Interceptor
className="org.apache.catalina.tribes.group.interceptors.MessageDispatch15In
terceptor"/>

          </Channel>

 

          <Valve className="org.apache.catalina.ha.tcp.ReplicationValve"

                 filter=""/>

          <Valve
className="org.apache.catalina.ha.session.JvmRouteBinderValve"/>

 

         

          <ClusterListener
className="org.apache.catalina.ha.session.JvmRouteSessionIDBinderListener"/>

          <ClusterListener
className="org.apache.catalina.ha.session.ClusterSessionListener"/>

        </Cluster>

[.]

 

 

And here the second tomcat:

[.]

<Engine name="Catalina" defaultHost="localhost" jvmRoute="worker7">

       

                               <Cluster
className="org.apache.catalina.ha.tcp.SimpleTcpCluster"

                 channelSendOptions="8">

 

          <Manager className="org.apache.catalina.ha.session.DeltaManager"

                   expireSessionsOnShutdown="false"

                   notifyListenersOnReplication="true"/>

 

          <Channel
className="org.apache.catalina.tribes.group.GroupChannel">

            <Membership
className="org.apache.catalina.tribes.membership.McastService"

                        address="228.0.0.4"

                        bind="178.30.5.77"

                        port="45574"

                        frequency="500"

                        dropTime="3000"/>

            <Receiver
className="org.apache.catalina.tribes.transport.nio.NioReceiver"

                      address="auto"

                      port="4000"

                      autoBind="100"

                      selectorTimeout="5000"

                      maxThreads="6"/>

 

            <Sender
className="org.apache.catalina.tribes.transport.ReplicationTransmitter">

              <Transport
className="org.apache.catalina.tribes.transport.nio.PooledParallelSender"/>

            </Sender>

            <Interceptor
className="org.apache.catalina.tribes.group.interceptors.TcpFailureDetector"
/>

            <Interceptor
className="org.apache.catalina.tribes.group.interceptors.MessageDispatch15In
terceptor"/>

          </Channel>

 

          <Valve className="org.apache.catalina.ha.tcp.ReplicationValve"

                 filter=""/>

          <Valve
className="org.apache.catalina.ha.session.JvmRouteBinderValve"/>

                                               

          <ClusterListener
className="org.apache.catalina.ha.session.JvmRouteSessionIDBinderListener"/>

          <ClusterListener
className="org.apache.catalina.ha.session.ClusterSessionListener"/>

        </Cluster>

[.]

 


Mime
View raw message