tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: AW: mod_jk - Browser displays HTML Sourcecode
Date Tue, 08 Nov 2011 16:37:38 GMT
Pid wrote:
> On 08/11/2011 15:54, André Warnier wrote:
>> But obviously it isn't, so there's something wrong with this JkMount.
> 
> Jumping ahead, that bit comes next when the OP's sorted their layout
> out... ;)
> 

Jumping back, the misdirected DocumentRoot issue should not be an immediate security
problem if the
JkMount /* loadbalancer
worked.
No ?
:-)

@Alexander :
change the VirtualHost's DocumentRoot to point anywhere else that is not part of the
Tomcat directories.
Then put a simple "index.html" document there, saying "wrong place".
(and make all of that readable by the user under which Apache httpd runs (like www-data
probably)).
Reload the Apache config.

After that, apart from the top-level "/" URL, everything else should return a 404 "not
found", until the JkMount works.

Then, in this :
<VirtualHost 192.168.100.40:80>
     ServerAdmin xxx@yyy
     DocumentRoot "D:/www/apps/app1/ROOT"
<Directory " D:/www/apps/app1/ROOT ">
		Options Indexes FollowSymLinks
		AllowOverride None
		Order allow,deny
		Allow from all
     </Directory>
...
</VirtualHost>

I don't see a JkMount.  Where is it ?




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message