tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin O'Shea" <app...@dsl.pipex.com>
Subject RE: Trying to get Tomcat 6 running as a Windows service
Date Wed, 16 Nov 2011 12:17:12 GMT
Thanks. Will try this later.

-----Original Message-----
From: Ilya Kazakevich [mailto:Ilya.Kazakevich@JetBrains.com] 
Sent: 16 Nov 2011 12 15
To: 'Tomcat Users List'
Subject: RE: Trying to get Tomcat 6 running as a Windows service

http://www.coderanch.com/t/450781/Tomcat/Tomcat-Windows-Server-Permissions 


Ilya Kazakevich,
Developer
JetBrains Inc
http://www.jetbrains.com
"Develop with pleasure!"

-----Original Message-----
From: Martin O'Shea [mailto:appy74@dsl.pipex.com]
Sent: Wednesday, November 16, 2011 3:59 PM
To: 'Tomcat Users List'
Subject: RE: Trying to get Tomcat 6 running as a Windows service

I've been trying to get the service running as per the attachment.

The account I am using does have admin rights.

The Jakarta Service log file reports:

[2011-11-16 11:54:30] [info] Commons Daemon procrun (1.0.2.0) started
[2011-11-16 11:54:30] [80   service.c] [error] Access is denied.
[2011-11-16 11:54:30] [524  prunsrv.c] [error] Unable to open the Service
Manager
[2011-11-16 11:54:30] [info] Commons Daemon procrun finished.

When I try to set the service up as displayed in the attachment.

-----Original Message-----
From: Ilya Kazakevich [mailto:Ilya.Kazakevich@JetBrains.com]
Sent: 16 Nov 2011 11 40
To: 'Tomcat Users List'
Subject: RE: Trying to get Tomcat 6 running as a Windows service

Which file do you run? "service.bat" ?

What do you have in your event logs?
Which account do you use for service? Does it have requried rights?


Ilya Kazakevich,
Developer
JetBrains Inc
http://www.jetbrains.com
"Develop with pleasure!"

-----Original Message-----
From: appy74@dsl.pipex.com [mailto:appy74@dsl.pipex.com]
Sent: Wednesday, November 16, 2011 3:36 PM
To: users@tomcat.apache.org
Subject: Trying to get Tomcat 6 running as a Windows service

Hello

I'm trying to get Tomcat 6.0.26 running as a service on a Windows 7 64 bit
PC but everytime I try I get message:

Failed installing 'Tomcat6' service.

As far as I'm aware, all relevant system settings are good and the
installation displays settings for CATALINA_HOME, CATALINA_BASE, JAVA_HOME
and JVM. I'm running the batch file with adminstrator authorities.

Has anyone any idea?

I should also add, that this version of Tomcat runs perfectly if called from
NetBeans 7.0.1 which is deployed on the same PC.

Martin O'Shea.
-- 



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message