tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Rush <da...@rushtone.com>
Subject Tomcat 7 won't run as Windows service
Date Fri, 14 Oct 2011 12:02:57 GMT
I've been running Tomcat 6.0.18 for a long time, and am now trying to 
upgrade to 7.0.22 (64 bit .zip download).

I can start Tomcat 7 with startup.bat and it's working fine.

The script to install it as a service worked without complaint, and the 
service is there.

However when I try to start it I get "Error 1067: The process terminated 
unexpectedly".

commons-daemon.2011-10-14.log says: [error] FindClass 
org/apache/catalina/startup/Bootstrap failed

I'm using Java 7 JDK (1.7.0, 64 bit), JAVA_HOME points to the JDK 
installation, and Java's "bin" is in my system path, on my Windows 7 
machine.

I'm using the setenv.bat in tomcat\bin that I copied from my Tomcat 6 
installation, which explicitly sets JAVA_HOME (which technically may not 
be necessary since I have JAVA_HOME env var set to the same value, but I 
need to have the option to support more that one JVM on my development 
box).  I've added a debug statement in setenv.bat that echoes something 
to a file.  When I run startup.bat, I get the echoed output.  When I try 
to start the service, I do not.

Help?

David

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message