tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Talha Fazal <>
Subject RE: Class not found exception
Date Thu, 08 Sep 2011 14:29:14 GMT
I ran into a similar issue. My mistake was that I was compiling the JSPs using Tomcat 6 compiler
and deploying it into Tomcat 7. Once I modified my ant build file to use jasper from my Tomcat
7 installation, and redeployed, it resolved the issue.


-----Original Message-----
From: Sonwabo Jordan [] 
Sent: Thursday, September 08, 2011 8:57 AM
Subject: Class not found exception

Good dayI am new to Tomcat (using ver 7.0 on windows XP) and have deployed a war file which
loads successfully using the Tomcat manger gui. However, when I try to run it I get the ff
exception:java.lang.ClassNotFoundException: org.apache.AnnotationProcessor org.apache.catalina.loader.WebappClassLoader.loadClass(
org.apache.catalina.loader.WebappClassLoader.loadClass( java.lang.Class.getDeclaredFields0(Native
Method) java.lang.Class.privateGetDeclaredFields( java.lang.Class.getDeclaredFields(
org.apache.catalina.authenticator.AuthenticatorBase.invoke( org.apache.catalina.valves.ErrorReportValve.invoke(
org.apache.catalina.valves.AccessLogValve.invoke( org.apache.catalina.connector.CoyoteAdapter.service(
org.apache.coyote.http11.Http11Processor.process( org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process($ java.util.concurrent.ThreadPoolExecutor$Worker.runTask(
have no clue what the exception is pointing to.ThanksSonwabo
Please find our Email Disclaimer here:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message