tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lunita <hoshi.uts...@gmail.com>
Subject Tomcat 7 :: Tomcat-Native
Date Thu, 29 Sep 2011 15:12:03 GMT
Hi all,

I'm trying to set up APR SSL, and at catalina.out is:

INFO: An older version 1.1.20 of the APR based Apache Tomcat Native library
is installed, while Tomcat recommends a minimum version of 1.1.22
Sep 29, 2011 5:07:40 PM org.apache.catalina.core.AprLifecycleListener init
INFO: Loaded APR based Apache Tomcat Native library 1.1.20.


So, I compiled 1.1.22, from several ways:


"./configure" \
"--prefix=/opt/apache-tomcat-7.0.21/" \
"--with-ssl=yes" \
"--with-java-home=/usr/java/jdk1.6.0_23/" \
"--with-apr=/opt/apr-1.4.2/" \
"$@"



"./configure" \
"--with-ssl=yes" \
"--with-java-home=/usr/java/jdk1.6.0_23/" \
"--with-apr=/opt/apr-1.4.2/" \
"$@"


And JAVA_OPTS at catalina:


export JAVA_HOME=/usr/java/jdk1.6.0_23
export CATALINA_HOME=/opt/apache-tomcat-7.0.21
export JAVA_OPTS="-Xms256m -Xmx912m -XX:PermSize=500m -XX:MaxPermSize=1024m
-Dorg.apache.catalina.loader.WebappClassLoader.ENABLE_CLEAR_REFERENCES=false
-Djava.library.path=/usr/java/jdk1.6.0_23/jre/lib/i386/client:/usr/java/jdk1.6.0_23/jre/lib/i386:/usr/java/jdk1.6.0_23/jre/../lib/i386:/usr/java/packages/lib/i386:/lib:/usr/lib:/opt/apache-tomcat-7.0.21/lib"


No way to load tomcat-native 1.1.22...

Any suggestions?

Thanks!!

Laura,

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message