tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francis GALIEGUE <...@one2team.com>
Subject Re: tomcat 7.0.21: bug in RemoteAddrValve?
Date Wed, 14 Sep 2011 15:42:55 GMT
On Wed, Sep 14, 2011 at 17:28, André Warnier <aw@ice-sa.com> wrote:
> Francis GALIEGUE wrote:
[...]
>>    <Valve className="org.apache.catalina.valves.RemoteAddrValve"
>>        allow="127\.0\.0\.1|::1"/>
[...]
>>
> Maybe try to modify that regexp somewhat, like to
> allow="(127\.0\.0\.1)|(::1)"
> or
> allow="127\.0\.0\.1|\:\:1"
> just in case the regexp library version changed, and it now interprets the
> original expression slightly differently ?

Nope... I also tried 127\.0\.0\.1 alone and no dice.

I'll try your two other suggestions but if any works, it means the
regex engine used is seriously buggy!

> Could it also be that previously, Tomcat saw an IPv4 address and it worked,
> but now it sees an IPv6 address and the "::1" part in fact never worked, but
> was never used before ?
>

The machine has IPv4 only. I just put in the ::1 in prevision of a not
so distant future...

But maybe it is some other part of the configuration (server.xml?
default context.xml?) which needs to be changed?

-- 
Francis Galiegue
ONE2TEAM
Ingénieur système
Mob : +33 (0) 683 877 875
Tel : +33 (0) 178 945 552
fge@one2team.com
40 avenue Raymond Poincaré
75116 Paris

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message